Closed Bug 1217187 Opened 4 years ago Closed 4 years ago

Extend the manifest field/value detection support to allow detecting role:homescreen and similar

Categories

(Core Graveyard :: DOM: Apps, defect)

defect
Not set

Tracking

(blocking-b2g:2.5+, firefox44 fixed)

VERIFIED FIXED
mozilla44
blocking-b2g 2.5+
Tracking Status
firefox44 --- fixed

People

(Reporter: sfoster, Assigned: _AtilA_)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file, 1 obsolete file)

Bug 900241 added the ability to detect some manifest fields and their support in a given b2g version, but for 2.5 we also need a way to detect the new role:"homescreen"
[Blocking Requested - why for this release]: Required by the marketplace to avoid presenting homescreen apps to users on <2.5 devices, where replaceable homescreens are not supported.
blocking-b2g: --- → 2.5?
blocking-b2g: 2.5? → 2.5+
Can the version number be used as a key instead?
Flags: needinfo?(sfoster)
(In reply to Andrew Overholt [:overholt] from comment #2)
> Can the version number be used as a key instead?

I think the Marketplace team is looking to avoid inferring specific feature support from a version number. But I'll let :ddurst respond as he is on the receiving end of this
Flags: needinfo?(sfoster) → needinfo?(ddurst)
Assignee: nobody → jgomez
Attachment #8677590 - Flags: review?(overholt)
Attachment #8677590 - Flags: review?(overholt) → review?(ehsan)
Comment on attachment 8677590 [details] [diff] [review]
Expose replaceable homescreen feature

Review of attachment 8677590 [details] [diff] [review]:
-----------------------------------------------------------------

This one also needs a test.
Attachment #8677590 - Flags: review?(ehsan) → review-
(In reply to Sam Foster [:sfoster] from comment #3)
> (In reply to Andrew Overholt [:overholt] from comment #2)
> > Can the version number be used as a key instead?
> 
> I think the Marketplace team is looking to avoid inferring specific feature
> support from a version number. But I'll let :ddurst respond as he is on the
> receiving end of this

Indeed we are looking to avoid inferring specific feature support from a version number, but also looking to the manifest role because that is the (only) indicator that differentiates a homescreen "app" from a regular webapp -- iow, it's a required manifest value for the homescreen content type.
Flags: needinfo?(ddurst)
Duplicate of this bug: 1217157
Attachment #8678814 - Flags: review?(ehsan) → review+
Keywords: checkin-needed
Whiteboard: [systemsfe]
https://hg.mozilla.org/mozilla-central/rev/3acb49afffb7
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
mars, ddurst and I ended up chatting.  In order to test this, launch the dev version of the marketplace, and search :debug

The flag for detections are down below.
Status: RESOLVED → VERIFIED
All the hasFeature() checks are there: addonsEnabled, homescreensEnabled, and lateCustomizationEnabled. If the checks return True, they'll be true.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.