Closed Bug 1217350 Opened 7 years ago Closed 7 years ago

[New Homescreen] Moving a finger in a circle on the homescreen looks ugly (scrolling on both axis at the same time)

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1222524

People

(Reporter: dscravaglieri, Unassigned)

References

Details

(Keywords: foxfood, polish, Whiteboard: [systemsfe])

Attachments

(1 file)

Move the finger in circle on the new homescreen, it shows part of the Pinning view and scroll down the homescreen main view vertically.

This looks ugly and already many people are complaining.
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
This is a platform issue - if we decide it's a blocker, I doubt we have any time to doing anything comprehensive about it for 2.5.

This would feel better if we disabled breaking out of axis-lock, or make it much much harder, but I'm not certain if that's something we want to do or not. I would vote for making it much harder though.
Not only is it ugly but it's a usability issue that's creating confusion. We are trying to present a two panel model to the user but instead the homescreen appears as single, continuous scrolling page.
Whiteboard: [systemsfe]
Do you have a suggestion for a better interaction? Given that we only have one week before code-complete, we can't block on feedback like this unless we have a clear understanding of the risk vs. reward of the proposed fix.
Flags: needinfo?(dscravaglieri)
Passing NI to the designer working on the feature - Liz.
Flags: needinfo?(dscravaglieri) → needinfo?(ehunt)
I don't think we can block on this, there's not enough we can do in the time we have left. There may be tweaks we can make to improve the situation, but blocking on what is essentially a platform feature bug is unrealistic.
blocking-b2g: 2.5? → ---
Depends on: 1222524
Our goal is to prevent scrolling on 2 axes at the same time. So if you're scrolling vertically, you're blocked from also scrolling horizontally, and vice versa.

This issue (and some other homescreen issues) would be mitigated/resolved by bug 1222524.
Flags: needinfo?(ehunt)
Duplicate of this bug: 1222702
Duplicate of this bug: 1215725
Making summary more keyword rich.
Summary: [New Homescreen] The behavior of new Homescreen looks ugly when move finger in circle on the homescreen → [New Homescreen] Moving a finger in a circle on the homescreen looks ugly (scrolling on both axis at the same time)
No longer blocks: new-homescreen
Keywords: foxfood, polish
Pretty confident in duping this to bug 1222524 - with that patch on that bug, it is impossible to do this.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1222524
No longer depends on: 1222524
You need to log in before you can comment on or make changes to this bug.