[Meta] Implement audio-interruption-begin/end event

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: alwu, Assigned: alwu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

3 years ago
When the audio competing ended,we have two behaviors for the previous interrupted audio, one is the auto-resumed by system app, another one is received the notification by system app that the app can decide whether or not resumes its audio. In present design, we can't split these behavior independently.

Therefore, we need to remove the old "moz-interrupted" event out from MediaElement/AudioContext, and implement the new event "audio-interruption" which is sent from the system app.

We'll go through with three stages,

(1) [Gecko] Implement the new methods in AudioChannelAPI

(2) [Gaia] Modify system app to use the new methods

(3) [Gaia] Modify all apps which are using the moz-interrupted event
(Assignee)

Updated

3 years ago
See Also: bug 1192748
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1192748
(Assignee)

Updated

3 years ago
Blocks: 1217139
(Assignee)

Updated

3 years ago
Depends on: 1223250
(Assignee)

Comment 2

2 years ago
No need to do that.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.