Mobile builds on try get uploaded to mobile/try-builds, used to be firefox/try-builds

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
3 years ago
a month ago

People

(Reporter: nthomas, Assigned: nthomas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
On stage in SCL3 we had a symlink
   mobile/try-builds --> firefox/try-builds
which kept everything together in firefox/try-builds/<user>-<rev>/. Then b2g came along and used b2g/try-builds.

When we moved to S3 for storage we started getting the binaries and test logs in mobile/try-builds, eg
http://archive.mozilla.org/pub/mobile/try-builds/bbirtles@mozilla.com-38b04db643dd89b79ee14ed153a35be26b2e094e/try-android-api-9/
while the build log is in
http://archive.mozilla.org/pub/firefox/try-builds/bbirtles@mozilla.com-38b04db643dd89b79ee14ed153a35be26b2e094e/try-android-api-9/

I'm thinking we should just upload the build log to go into mobile/try-builds. Need to track down how that is happening.
Do we have an ETA for fixing this bug? To make sure this is the right bug, clicking the link next to "Build:" in treeherder only lists a txt.gz file, rather than the builds I expect it to – I believe this bug is to fix that.

I have a work-around to search for "packageURL" in the txt.gz file (which makes it just annoying for me) but the rest of my team and volunteers may not be aware.
Flags: needinfo?(nthomas)
Flags: needinfo?(catlee)
Duplicate of this bug: 1224687
Folks, movement on this, please.  I'm tired of wading through multi-megabyte txt.gz files to copy-paste a link.
I'm not sure if this about the same bug. We can fix the log uploads, but I'm not sure that will necessarily make treeherder links work. If it's basing the build directory link on where it's finding the log, then it should work.
Flags: needinfo?(catlee)
(In reply to Nick Alexander :nalexander from comment #3)
> Folks, movement on this, please.  I'm tired of wading through multi-megabyte
> txt.gz files to copy-paste a link.

A simpler workaround is to s/firefox/mobile/ in the link that treeherder gives you.
(In reply to Chris AtLee [:catlee] from comment #4)
> I'm not sure if this about the same bug. We can fix the log uploads, but I'm
> not sure that will necessarily make treeherder links work. If it's basing
> the build directory link on where it's finding the log, then it should work.

What we have to do now is documented at https://mail.mozilla.org/pipermail/mobile-firefox-dev/2015-November/001630.html

I don't know what the underlying issue is, but Fennec team shouldn't have to do that process forever.
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #5)
> (In reply to Nick Alexander :nalexander from comment #3)
> > Folks, movement on this, please.  I'm tired of wading through multi-megabyte
> > txt.gz files to copy-paste a link.
> 
> A simpler workaround is to s/firefox/mobile/ in the link that treeherder
> gives you.

Fine, let's make this ticket track exposing that link in TreeHerder then.  We need to fix this rather than propagate work-arounds to a subset of people.
This is due to these lines:
https://dxr.mozilla.org/build-central/source/buildbot-configs/mozilla/config.py#2644

introduced as part of bug 557260, some of the initial mobile automation work!
(Assignee)

Comment 9

3 years ago
Created attachment 8691048 [details] [diff] [review]
[buildbot-configs] Let stage_product be the default value of mobile
Assignee: nobody → nthomas
Flags: needinfo?(nthomas)
Attachment #8691048 - Flags: review?(catlee)

Updated

3 years ago
Attachment #8691048 - Flags: review?(catlee) → review+
(Assignee)

Comment 11

3 years ago
Treeherder is now giving links like http://archive.mozilla.org/pub/mobile/try-builds/nthomas@mozilla.com-10d07a6ab962cc0e3b8be3dc6859928ac6391448/try-android-api-11/ for 'Build', and that contains apk's, test files, logs for builds and tests.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(In reply to Nick Thomas [:nthomas] from comment #11)
> Treeherder is now giving links like
> http://archive.mozilla.org/pub/mobile/try-builds/nthomas@mozilla.com-
> 10d07a6ab962cc0e3b8be3dc6859928ac6391448/try-android-api-11/ for 'Build',
> and that contains apk's, test files, logs for builds and tests.

Much better.  Thanks, everybody!
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.