Unimplemented methods should log a message instead of silently doing nothing.

RESOLVED DUPLICATE of bug 1223585

Status

RESOLVED DUPLICATE of bug 1223585
3 years ago
3 months ago

People

(Reporter: bwinton, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
In particular, there was nothing to indicate why my attempted port of the Chrome extension "Earth View from Google Earth" failed, because it was calling chrome.runtime.onInstalled which is defined to be `ignoreEvent()`
(at https://dxr.mozilla.org/mozilla-central/source/toolkit/components/extensions/ext-runtime.js#40) and ignoreEvent doesn't say what happened (at https://dxr.mozilla.org/mozilla-central/source/toolkit/components/extensions/ExtensionUtils.jsm#233).  ignoreEvent shouldn't throw an error, I don't think, but it would be nice if it told us what it was ignoring, so that we could get a list of things we needed to add/fix.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1223585

Updated

3 years ago
Iteration: --- → 45.1 - Nov 16

Updated

3 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.