JS menu item covered by flash ad

RESOLVED DUPLICATE of bug 111920

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 111920
17 years ago
16 years ago

People

(Reporter: Itamar, Assigned: asa)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ Dupe of bug 111920? ], URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
JS dynamic menu items are painted under a flash presentaion.
using 2002 01 24 03 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.7+) Gecko/20020124
To reproduce:
1.open http://www.mutek.com/
2. move the mouse over the "Partners" menu
Actual:
A dynamic drop down menu opens and its lower part is covered by the flash
presentaion
Should be:
the JS menu should be painted over the flash ad

Note:
works fine in IE 5.0 and 5.5

Comment 1

17 years ago
Browser, not engine. Reassigning to Browser-General until we can get
more information. WORKSFORME using Mozilla binary 20020125xx on WinNT.
When I mouse over the "Partners" menu item, a drop-down menu appears
consisting of

                   Strategic Alliances
                   Mutek Service & Reseller Partners
                   Become a Partner
                   International Distributors


None of this comes near the Shockwave Flash element, which is the
big circle in the middle of the page. If I click on the Flash element
to begin the presentation, the "Partners" menu continues to work
properly, and appears on top of the underlying Flash text -
Assignee: rogerl → asa
Component: JavaScript Engine → Browser-General
QA Contact: pschwartau → doronr
(Reporter)

Comment 2

17 years ago
Damn, :-(
The website has changed - I see what you mean.
The Flash ad is much lower then before.
I'm not closing yet since I'm gonna try and create a reduced testcase.

Comment 4

17 years ago
Created attachment 67339 [details]
Flash takes priority in stacking order

Not sure what the standards say, but browsers are pretty consistant with
rendering flash over layers

Comment 5

17 years ago
Confirming on WinNT, Linux based on Dave's test. OS: Win98 ---> All.
Reassigning to Layout. As Dave suggests, this looks like a dup of bug 111920 - 
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
OS: Windows 98 → All
Hardware: PC → All
Whiteboard: [ Dupe of bug 111920? ]
(Reporter)

Comment 6

17 years ago
Created attachment 67407 [details]
Ad flash over menus in mutek website

Well after creating this hatml by deleting unneeded tags from the original
mutek website I found out that IE 5 and 5.5 fasils it too.
And after seeing the dup comment I'm not sure if it is a bug anymore.
I guess its a shme Idon't have the originl html code that worked in IE 5 and
5.5

Comment 7

16 years ago
Confirmed on IE 6 and NS4.x as specified in bug 111920 flash takes priority in 
the stacking order rendering dhtml layers behind it...  The question now is, is 
that experience based on standards (w3c), is it actually a bug in all browsers? 
Couldn't find anything about it at w3c...  

Updated

16 years ago
Blocks: 113492

Updated

16 years ago
QA Contact: doronr → petersen

Comment 8

16 years ago
Here's another website example of what I'm assuming to be
similar behaviour. (I'm using 2002020406 / Win95)

http://www.miami.com/mld/miamiherald/living/columnists/dave_barry/2779904.htm

The dynamic menus near the top of the page (Business, Sports, etc.) go under
the banner ad.
(Reporter)

Comment 9

16 years ago
I'm not sure this is the same bug.
In the 2nd attachment you can see the menus painted under the flash banner.
in this case there is no flash banner (but a regualr gif) and the menus are
painted over the banner(as the should) but the menu disappears as soon as you
move the mouse pointer over a menuitem that is painted over the banner.
I guess the we see 2 different things because I have 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+) Gecko/20020306.
Kyle please download a new nightly or atleast 0.9.8 are try again.
I think what you reported is not related to this bug - but should be submitted
as a new bug.

Comment 10

16 years ago
Actually, that *was* the 0.98 version. But you're right -- I just installed
2002030604, and I can't reproduce that problem anymore. I guess I won't submit
a new bug, since it seems to be fixed already...

(Reporter)

Comment 11

16 years ago
But can you select the menus that are over the image?
As soon as I pass the mouse pointer over them - they disappear.

Comment 12

16 years ago
Sigh. You're right again. I've filed it as Bug 129518 now.

Sorry for the spam on this bug.


Comment 13

16 years ago

*** This bug has been marked as a duplicate of 111920 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
No longer blocks: 113492
You need to log in before you can comment on or make changes to this bug.