Flash overlapping DHTML menus, due to missing wmode="transparent"

VERIFIED INVALID

Status

()

Core
Plug-ins
VERIFIED INVALID
17 years ago
9 years ago

People

(Reporter: Olivier Cahagne, Assigned: av (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Build ID: 2001112508 on Win2k, Flash 5.0r41.

Steps to reproduce bug:
1. Load URL http://www.intel.fr/eBusiness/products/desktop/
2. Mouse over left menus (example: Inscription)
3. See DHTML menu going behind the Flash content.

Expected results:
DHTML should be over Flash content, it works with IE6 on Win2k, Netscape 4.76
(using same Flash plug-in, 5.0r41).

Don't know whether to report this bug in Layout or Plug-ins though.
(Reporter)

Comment 1

17 years ago
Also happen on Linux with latest nightly build (000000000 ? weird build ID btw
:) + Flash 5.0r47.
OS -> All
OS: Windows 2000 → All
plugins
Assignee: asa → av
Component: Browser-General → Plug-ins
OS: All → Windows 2000
QA Contact: doronr → shrir

Comment 3

17 years ago
On IE you're replacing the swf with an image or non-flash content.  But your 
function for swapping out the content doesn't work for Mozilla.

Expected Results should actually be flash is replaced by image in IE6 and NS 
4.76.

Check to make sure you're accessing the correct DOM properties for Mozilla.

BTW Flash will(should) always be on top of DHTML

Comment 4

17 years ago
Looks like the script is hiding the parent DIV but the containing plugin isn't
being hidden.

Updated

17 years ago
Blocks: 113492
(Reporter)

Comment 5

17 years ago
URL is now a 404, the bug still remains however but building a testcase for this
(DHTML+Flash) is out of my possibilities. :(

Comment 6

17 years ago
I don't think this is a mozilla bug as it's a known restriction of DHTML, being 
that layers cannot be over flash...

Happens in all other browsers... also form objects and other embeded objects 
normally take priority (z-index)
(Assignee)

Comment 7

17 years ago
Marking INVALID based on the previous comment.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

17 years ago
As I first mentioned in my bug report, this bug doesn't happen with IE6 nor
Netscape 4.76, I just re-verified with following URL:
http://www.intel.fr/eBusiness/index.htm

Comment 9

17 years ago
You will find information here:  
http://developer.netscape.com/docs/manuals/communicator/dynhtml/index.htm 
regarding the fact the plugins, applets and forms take the highest most 
priority in the window... and if you keep looking you'll see that recently 
Communicator has introduced window-less plugins allowing layers to be on top of 
some plugins (Which is terrific since it is not backwards compatible)...

Finally, if you really, really look at the page, you'll notice that the SWF is 
replace by an image when you rollover the left nav (IE 6) So the layer isn't 
truly over flash, it's over an image.

Comment 10

17 years ago
Verified on IE6 and NS 4.76 as poor programming, not a mozilla bug.

Checked IE 6 and NS4.76 pc, site uses DHTML to replace the swf with an image 
when you mouseover the left nav (displaying the layer).  It appears they didn't 
take the time to test this in Mozilla.

Comment 11

17 years ago
v-i
Status: RESOLVED → VERIFIED

Comment 12

17 years ago
*** Bug 121802 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
*** Bug 167524 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
*** Bug 183446 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
*** Bug 217402 has been marked as a duplicate of this bug. ***

Comment 16

15 years ago
*** Bug 219207 has been marked as a duplicate of this bug. ***

Comment 17

15 years ago
*** Bug 229523 has been marked as a duplicate of this bug. ***

Comment 18

15 years ago
The URL´s in this bug don´t show the behaviour, so here is a new one:
http://sportsillustrated.cnn.com/baseball/mlb/
'MLB' is a flash menu, and hides part of the menus from above, 'NFL' ... 'Scores'

http://sportsillustrated.cnn.com/more/
'More Sports' is a gif, overlapped by the menues from above, hover over 'NFL'
... 'Scores'

This is from Bug 218187	Main page dropdown menu is correct but subsection
baseball, nfl etc dropdown menu is mangled due to flash

testcase 33 kb zipped
http://bugzilla.mozilla.org/attachment.cgi?id=130928&action=view

testcase MLB, needs flash, is working offline: unzip into a directory, start
MLB.html

feel free to dupe, if the bug fits this bugs description.

Is sportsillustrated.cnn.com an umimportant minor website, or should it be 'Tech
Evangelized' ?

I´m not seeing this bug in Netscape 4.79, as there are no expanding menus on the
subpage, menus are shown only http://sportsillustrated.cnn.com

I´m also seeing this bug using Opera 7.23
Tested on Win98, Win98SE, starting with Mozilla 1.3, up to now, using Flash 7.0 r19
*** Bug 223911 has been marked as a duplicate of this bug. ***

Comment 20

14 years ago
Is this 'bug' responsible for the menu-effect on this page
http://tw.giga-byte.com/ ? (tested with Firefox 0.8)
(Reporter)

Comment 21

14 years ago
(In reply to comment #20)
> Is this 'bug' responsible for the menu-effect on this page
> http://tw.giga-byte.com/ ? (tested with Firefox 0.8)
Yes, they should probably upgrade to CoolMenus v4:
http://tw.giga-byte.com/Scripts/coolmenus3.js

*** Bug 278001 has been marked as a duplicate of this bug. ***
*** Bug 310731 has been marked as a duplicate of this bug. ***

Comment 24

13 years ago
http://www.dfi.com.tw/index_us_noflash.jsp?SITE=NA

Menu's are behind the banner ad, cant be clicked.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.12) 
Gecko/20050915

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b5) 
Gecko/20050926 Firefox/1.4

Menus are in front of the banner ad so they can be clicked as 
they should be.

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) 
Gecko/20050920

Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8b5) 
Gecko/20050927 Firefox/1.4
(Win32 only bug?)

SuSE Linux 9.2 Pro x86_64 - KDE 3.3.0

Comment 25

13 years ago
(In reply to comment #24)
> http://www.dfi.com.tw/index_us_noflash.jsp?SITE=NA
> 
> Menu's are behind the banner ad, cant be clicked.

Reason for this is that they don't include wmode="transparent" to the embed. You
can contact them if you want and inform them about it.
Summary: Flash overlapping DHTML menus → Flash overlapping DHTML menus, due to missing wmode="transparent"
*** Bug 332249 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Duplicate of this bug: 333972

Updated

11 years ago
Duplicate of this bug: 357100
Duplicate of this bug: 403917

Comment 30

11 years ago
I still have this problem with flash 9 and FFx 2.0.0.11 (gentoo build).  I keep seeing in these bugs that people need to include wmode="transparent", but http://tw.giga-byte.com has that, and so does http://canonusa.com

Neither of them are working.
Duplicate of this bug: 434575

Comment 32

10 years ago
well, even with ffx 3rc2 (both linux & windows), flash still overlapping dhtml menus, eg: http://www.gettyimages.com

and i found many bugs was reported, but none of them resolved:(

Duplicate of this bug: 438787

Updated

9 years ago
Duplicate of this bug: 352974

Comment 35

9 years ago
I think this bug has been fixed quite a long time ago. Take a look at http://www.nvidia.com. Menus are on top above the flash animation, and they're even transparent. It used to work bad, but right now it works fine. I am using Firefox 3.5b4 from Fedora 11 (Linux).

Comment 36

9 years ago
On Linux you can layer an iframe in front of a Flash without wmode=transparent but on Windows you cannot
You need to log in before you can comment on or make changes to this bug.