pageAction extension no longer works after browser restart

RESOLVED DUPLICATE of bug 1218443

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1218443
2 years ago
2 years ago

People

(Reporter: anaran, Unassigned)

Tracking

(Blocks: 1 bug, {DevAdvocacy})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pageAction])

(Reporter)

Description

2 years ago
The extension needs to be disabled and enabled again in about:addons.

Then it starts working again.

I have observed the same behaviour when using the chrome namespace instead of the browser namespace in background.js.


+++ This bug was initially created as a clone of Bug #1197422 +++

https://developer.chrome.com/extensions/pageAction

API is listed on https://wiki.mozilla.org/WebExtensions#List_of_APIs_we_will_likely_support_in_the_future
(Reporter)

Updated

2 years ago
No longer blocks: 1190321, 1200674, 1203738, 1208765
No longer depends on: 1197422
Works for me. Do you have a testcase?
(Reporter)

Comment 2

2 years ago
I am just using you test-panel.xpi from Bug #1197422.

It works after I install it in nightly Firefox, on the Windows XP machine with latest nightly.

Then I File->Quit Firefox and start it again.

Now the PageAction icon does not show. The Browser Action icon is there.

After I disable and enable the add-on in about:addons the pageAction icon becomes visible again.

I did switch tabs to make sure the listener should get triggered, but it only works after disable/enable after a browser restart.
I think that just has something to do with the way the add-on is implemented, and the order that the listeners are dispatched. I have other test add-ons that work as expected after a restart.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1218443
Since this seems to have been fixed, I'm removing dev-doc-needed.
Keywords: dev-doc-needed
I think that was just there because this bug was cloned from a bug that actually needed it.
You need to log in before you can comment on or make changes to this bug.