test_homescreen_launch_app.py : TimeoutException: TimeoutException: Timed out after 30.3 seconds

RESOLVED DUPLICATE of bug 1218108

Status

Firefox OS
Gaia::UI Tests
RESOLVED DUPLICATE of bug 1218108
3 years ago
3 years ago

People

(Reporter: MaxIvanov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Description: Test case fails with "TimeoutException"

Steps:
1. Update a flame device to 20151026030217
2. Run this test case http://lxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/tests/functional/homescreen/test_homescreen_launch_app.py

Actual result:
"TimeoutException"

Expected result:
Test completes successfully.

Repro Rate: Reproduced via Jenkins adhoc (0/5 passing)
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc.bitbar/312/HTML_Report/

Traceback (most recent call last):
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-1.0.0-py2.7.egg/marionette/marionette_test.py", line 277, in run
self.setUp()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/homescreen/test_homescreen_launch_app.py", line 37, in setUp
system.wait_for_system_banner_displayed()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/system/app.py", line 54, in wait_for_system_banner_displayed
Wait(self.marionette).until(expected.element_displayed(*self._system_banner_locator))
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_driver-1.0.0-py2.7.egg/marionette_driver/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 30.3 seconds
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1218108
You need to log in before you can comment on or make changes to this bug.