When user inputs half of the password and check the "show password", the cursor moves the front of inputted string.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
6 months ago

People

(Reporter: liuke, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-v2.5 affected, b2g-master affected)

Details

(Whiteboard: [2.5-aries-test-run-3])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8679351 [details]
Bug log: logcat_2245.txt

[1.Description]:
[Aires KKv2.5][Flame KK v2.5][keyboard]When user connects to a Wifi,  but only input half of the password and check the "show password", the cursor moves to the front of inputted string.
See video: "Flame KK v2.5.3GP"
See log: "logcat_2245.txt"
Found time:  22:45

[2.Testing Steps]: 
1.Launch the Settings.
2.Select the Wifi.
3.Connect to a Wifi Access point.
4. Input half of the password .
5. Check the "show password.

[3.Expected Result]: 
5. When the password is displayed, the cursor should locate behind the inputted string.

[4.Actual Result]: 
5.When the password is displayed , the cursor moves the front of inputted string.

[5.Reproduction build]: 
Device: Aries KK 2.5 (Affected)
Build ID               20151026223015
Gaia Revision          b564b21e08ffc3e4962f08850843c7482932ee7b
Gaia Date              2015-10-26 14:22:21
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6c7c983bce46a460c2766fbdd73283f6d2b03a69
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151026.214940
Firmware Date          Mon Oct 26 21:49:48 UTC 2015
Bootloader             s1

Device:FlameKK 2.5  (Affected)
Build ID               20151026030217
Gaia Revision          a677ddd3aa3a81058775938bd56008d96dbc78b0
Gaia Date              2015-10-26 04:48:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5ca03a00d26823ce91ee0eaa2937bed605bd53c1
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151026.070911
Firmware Date          Mon Oct 26 07:09:23 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device:FlameKK 2.2  (Unaffected)
Build ID               20151026032516
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9e0aa88fea7a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151026.073113
Firmware Date          Mon Oct 26 07:31:24 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free test
(Reporter)

Comment 1

3 years ago
Created attachment 8679353 [details]
Video: Flame KK v2.5.3GP
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
See Also: → bug 1054570
status-b2g-v2.5: --- → affected
Keywords: regression
b2g-inbound Regression Window

Last Working Environmental Variables:
Device: Flame master 512mb
Build ID               20150713205349
Gaia Revision          66638d0e65bf58b7f640bcc7bed4a0b23d1356c6
Gaia Date              2015-07-14 03:28:52
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/5bd5ca3ad614
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151124.070911
Firmware Date          Tue Nov 24 07:09:23 EST 2015
Firmware Version        V18D V4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame master 512mb
Build ID               20150713210445
Gaia Revision          8c9edeee3a385d60bb6f7b020a6bbf3ad6706740
Gaia Date              2015-07-14 03:33:35
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/81347c6021da
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151124.070911
Firmware Date          Tue Nov 24 07:09:23 EST 2015
Firmware Version        V18D V4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko – issue DOES repro
Gaia Revision          8c9edeee3a385d60bb6f7b020a6bbf3ad6706740
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/5bd5ca3ad614

First Broken Gecko & Last Working Gaia – issue DOES NOT repro
Gaia Revision          66638d0e65bf58b7f640bcc7bed4a0b23d1356c6
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/81347c6021da

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/66638d0e65bf58b7f640bcc7bed4a0b23d1356c6...8c9edeee3a385d60bb6f7b020a6bbf3ad6706740

Note:
The keyboard hides automatically when user checks "show password" on Flame v2.2 and the builds older than 20150713205349 of Flame master. So this bug can't be repro and is blocked by that.
QA Whiteboard: [MGSEI-Triage+]
Hi Kevin,

According to comment 2 gaia pushlog, could you please have a look at this bug? thanks :)
Flags: needinfo?(kevin+bugzilla)
One quick fix here would be to use a javascript focus() call, but that might not always focus in the desired location. I haven't yet found a CSS only fix for this.
Flags: needinfo?(kevin+bugzilla)
See Also: → bug 942865
Duplicate of this bug: 1229232

Comment 6

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.