HTML attachment overlaps other content when using position:absolute

RESOLVED DUPLICATE of bug 31052

Status

MailNews Core
Attachments
RESOLVED DUPLICATE of bug 31052
16 years ago
4 years ago

People

(Reporter: Nicolás Lichtmaier, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
I've attached an HTML document to a newsgroup which used "position: absolute;
top: 0px; bottom: 0px; right; 0px; left: 0px" and it overlapped other MIME parts
in the message. It seems that coordinates are relative to the message window,
instead of being relative to the attachment area. The message is posted in
n.p.m.style and this is the URL:
news://news.mozilla.org:119/3C510B16.1010104@technisys.com.ar .

I'm using build 2002012408

Comment 1

16 years ago
When I go to the URL I see a (pretty broken -- charset) text message. Does the
problem still happen? If so, please attach the message in question.

pi
(Reporter)

Comment 2

16 years ago
Well, of course. You need to open it in mail-news, not in the browser. The post
was (looking in the headers) in netscape.public.mozilla.style .
(Reporter)

Comment 3

16 years ago
I've just reproduced it again in a recent Mozilla, confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
I just ran into this problem with:

Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030306

Here is HTML code that reproduces the problem when viewed as an inline email
attachment:

<html>
<head>
<title>Mozilla bug</title>
</head>
<body>
<div style="position:absolute; top:0px">
    This is inside of <b>div</b> w/ <b>style="position:absolute; top:0px"</b>.
    <br>
    <i>
    When viewed as an inline email attachement it 
    is displayed over the top of the message text, 
    not down below in the inline attachment area.
    </i>
</div>
</body>

</html>
Product: Browser → Seamonkey

Comment 5

13 years ago
Still see the problem with:

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050217

Updated

13 years ago
Assignee: sspitzer → mail

Comment 6

13 years ago
bug #221559 seems to be a duplicate. It contains another file for triggering the
bug. Still happening with mozilla 1.7.7.

Comment 7

12 years ago
*** Bug 186316 has been marked as a duplicate of this bug. ***

Comment 8

12 years ago
*** Bug 221559 has been marked as a duplicate of this bug. ***

Comment 9

12 years ago
This occurs in TB as well; moving to Core.
Component: MailNews: Main Mail Window → MailNews: Attachments
OS: Linux → All
Product: Mozilla Application Suite → Core
Hardware: PC → All

Comment 10

12 years ago
I'm not sure if this is helpful, but I have determined that position:absolute works correctly if top and bottom are not set, or are set to auto.  This might not apply to all cases, but it did work for my local installation of TWiki (http://www.twiki.org) where I removed top from .twikiLeftBar in layout.css.  

Updated

10 years ago
Assignee: mail → nobody
QA Contact: esther → attachments
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
Can someone try to reproduce this bug with a recent build of TB (http://stage.mozillamessaging.com/en-US/thunderbird/early_releases/downloads/) , and comment here telling us if this issue is still present in the product ?

Comment 12

9 years ago
I have reproduced the problem with TB 3.0b2.  I created an HTML email using the HTML in Comment #4.  I then forwarded that email as an attachment.  When the attachment is displayed inline, the text inside <div style="position:absolute; top:0px"> is displayed at the top of the message body area, overlapping the message body text, not at the bottom of the message body area below the attached emails headers where it should be.  Please email me directly if you need help reproducing this.

Comment 13

9 years ago
It can also be reproduced using the current seamonkey-1.0.9-35.el4.centos RPM on CentOS/RHEL 4.7.

Comment 14

9 years ago
Dupe of the bug about not applying attachment css to the mail body as well. (Can't find it atm.)
Whiteboard: DUPEME

Comment 15

5 years ago
Created attachment 801262 [details]
Testcase1.eml: Message with position:absolute in body of attached HTML file

Testcase1.eml message using HTML attachment from comment 4.
Confirming bug as described: inline preview of HTML attachment leaks into message body text, making both unreadable. TB is always good for astonishment.

Comment 16

5 years ago
Created attachment 801265 [details]
Screenshot 1: Testcase1.eml displayed in TB: HTML attachment's inline preview overlaps message body, causing visual havoc

Nasty visual effect...

Comment 17

5 years ago
(In reply to Magnus Melin from comment #14)
> Dupe of the bug about not applying attachment css to the mail body as well.
> (Can't find it atm.)

Magnus, thanks for setting Dupeme flag on whiteboard, that's very helpful to follow up on these as I'm doing atm. Every hint helps, and this sort of proves my point that we should encourage Ben to accept longer summaries with generic search words so that it's easier to find duplicates...
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 31052

Updated

5 years ago
Whiteboard: DUPEME

Updated

4 years ago
See Also: → bug 741696
You need to log in before you can comment on or make changes to this bug.