With "Display Attachments Inline", contents from attachment having HTML tags with absolute positioning will overlay main message body display [css/cover/override/spill into/mess up]

RESOLVED DUPLICATE of bug 31052

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 31052
6 years ago
4 years ago

People

(Reporter: hwaki@ashisuto.co.jp, Unassigned)

Tracking

(Blocks: 1 bug)

11 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

6 years ago
Created attachment 611723 [details]
Thunderbird setting and display a message

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120310010446

Steps to reproduce:

I recevied some E-Mail.
There are attached HTML including absolute position in SPAN-tag.



Actual results:

When I checking " Display Attachments Inline" on Thunderbird, I see the contents outside of HTML display area.


Expected results:

It should display within HTML display area.
Thank you for your report.

Can you please attach the problematic html file too?

Next time you attach file, do not use zip, please. Bugzilla can handle image files(png, jpeg and etc. etc.).
Created attachment 611726 [details]
The screenshot extraced from attachment 611723 [details]
(Reporter)

Comment 3

6 years ago
Created attachment 611733 [details]
Attached sample HTML file
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

6 years ago
I'm sorry for my uploaded file.
And I also uploaded sample HTML file.
Please confirm it.

Best Regards,
Hiroyoshi Waki

Comment 5

6 years ago
Similar effect. Sent a plain text email with a single html file attached, which also uses absolute positioning. Images from the html appear over the email text.

I will attach (a) a screenshot (b) the html

The two blue arrows are the images in the div id="button_space"

It's a normal multipart/mixed message with 2 parts.

User-Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Thunderbird/17.0

Comment 6

6 years ago
Created attachment 695163 [details]
Screenshot (a) see comment 5

Screenshot showing images from html file on top of email text

Comment 7

6 years ago
Created attachment 695164 [details]
html attachment (b) see comment 5

html attachment (b) see comment 5
Thanks for reporting and screenshots etc...

Duplicate of bug 31052 which has many flavors, but same cause for all (involving age-old deficiencies of seamless iframe iirc).
Blocks: 714489
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
See Also: → bug 121878
Summary: When checking Display Attachments inline, Including absolute position SPAN-tag in HTML is override messages → With "Display Attachments Inline", contents from attachment having HTML tags with absolute positioning will overlay main message body display [css/cover/override/spill into/mess up]
Duplicate of bug: 31052
(In reply to Thomas D. from comment #8)
> Thanks for reporting and screenshots etc...
> 
> Duplicate of bug 31052 which has many flavors, but same cause for all
> (involving age-old deficiencies of seamless iframe iirc).

Indeed, the saga of Bug 80713 which blocks many important bugs like bug 31052. I've tried really hard to get some traction on Bug 80713, but without luck. It's somewhat hard to do and nobody seems to care much. Shame.
You need to log in before you can comment on or make changes to this bug.