If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Duplicate add-ons are displayed in the search results

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Search
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Madalin Cotetiu, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

2 years ago
Steps to reproduce:
1. Open addons stage homepage: https://addons.allizom.org/en-US/firefox/
2. Perform a search by entering a string in the search field and clicking the green arrow.
3. Order the results by most users.

Expected results:
Relevant add-ons are displayed, there are no duplicates.

Actual results:
All the add-ons are displayed 2 times in the search result list.

Notes/Issues:
Verified in FF41(Win7) Issue can be reproduced only in amo-stage.
Screencast for this issue: http://screencast.com/t/lRNcocbup7

Comment 1

2 years ago
Not occurring on dev or prod, could be AWS move related?
Flags: needinfo?(jthomas)
There were two indices associated with the alias. I did run the reindex command twice but I think the command should have removed the old index once the new index was populated. 

curl http://elasticsearch-amostage1.amo.us-east-1.stage.mozaws.net:9200/_aliases?pretty=true
{
  "addons_stage-20151022144239" : {
    "aliases" : {
      "addons_stage" : { }
    }
  },
  "addons_stage-20151022142717" : {
    "aliases" : {
      "addons_stage" : { }
    }
  },
  "addons_stats_stage-20151022144239" : {
    "aliases" : {
      "addons_stats_stage" : { }
    }
  },
  "addons_stats_stage-20151022142717" : {
    "aliases" : {
      "addons_stats_stage" : { }
    }
  }
}

I manually deleted the two old indices and I am going to run the reindex command again on stage.
Flags: needinfo?(jthomas)
(Reporter)

Comment 3

2 years ago
The issue is no longer reproducing in stage: http://screencast.com/t/w0qFYyrS0hbp
Can you please mark the bug as fixed, if the work here is done, so we can properly close the bug?

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.