Running without --restart option broken, because of wrong code in touch_home_button

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: Martijn Wargers (dead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
I caused this in bug 1217870.
This caused the Sunspider test on https://arewefastyet.com/#machine=26 to fail:
https://github.com/nbp/gaia-ui-tests/blob/bench/gaiatest/tests/browser/benchmarks/test_bench_sunspider.py#L19

Comment 1

2 years ago
Created attachment 8680071 [details] [review]
[gaia] mwargers:1219279 > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Attachment #8680071 - Flags: review?(npark)
Attachment #8680071 - Flags: review?(jlorenzo)
(Assignee)

Comment 2

2 years ago
The fix in running_apps was also needed for me to get test_bench_sunspider.py working (and there was another unrelated issue which I saw, but I'm working already on that in another bug).
(Assignee)

Comment 3

2 years ago
I saw this also failing in test_browser_clear_browsing_history.py, so we would have caused this failure in our own tests, too.
Comment on attachment 8680071 [details] [review]
[gaia] mwargers:1219279 > mozilla-b2g:master

If it runs, it looks good to me. let me know if you want me to test it out locally.
Attachment #8680071 - Flags: review?(npark) → review+
Comment on attachment 8680071 [details] [review]
[gaia] mwargers:1219279 > mozilla-b2g:master

Looks good to me. Sorry I missed the lambda during the review.
Attachment #8680071 - Flags: review?(jlorenzo) → review+
(Assignee)

Comment 6

2 years ago
Merged: https://github.com/mozilla-b2g/gaia/commit/b8347d5cc4815da673f38fce84c7c20728b71466
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1219364
You need to log in before you can comment on or make changes to this bug.