Closed Bug 12194 Opened 21 years ago Closed 21 years ago

problems setting visibility dynamically

Categories

(Core :: CSS Parsing and Computation, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 13047

People

(Reporter: dbaron, Assigned: peterl-retired)

Details

DESCRIPTION:  The test case is a sidebar demo XUL file that sets visibility
dynamically as a workaround for bug 9013.  However, the setting only works the
first time.  After you set it to visible, and then hidden, it can't be shown
again.

STEPS TO REPRODUCE:
* Download the four files in http://www.fas.harvard.edu/~dbaron/nstmp/M9-4-bad1/
* load when-com.xul in viewer or in the sidebar of apprunner (by editing
chrome://sidebar/content/sidebar-browser.rdf and giving
<NC:height>170px</NC:height> as well.
* Click "Add" (...wait until stuff shows up)
* Click "List" (... "")
* Click "Add"

ACTUAL RESULTS:  After clicking "Add" the second time, nothing shows up.

EXPECTED RESULTS: Can keep switching between the two panels ad infinitum and
they will still always show up.

BUILDS TESTED:
 * Linux, apprunner, 1999-08-16-08-M9
 * Linux, viewer, 1999-08-16-08-M9.

ADDITIONAL INFORMATION:  You don't know a workaround for this (or bug 9013), do
you?
Probably a duplicate of 10402?
chrisd, can you check Win and Mac please?
I think this should be resolved as a dup of bug 13047, but I'm not sure...
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 13047 ***
Status: RESOLVED → VERIFIED
Verified bug a dup of #13047
You need to log in before you can comment on or make changes to this bug.