CSS-Visibility can´t be changed

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED INVALID
19 years ago
18 years ago

People

(Reporter: maikmerten, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Windows 95
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] [new])

Attachments

(3 attachments)

(Reporter)

Description

19 years ago
Hello,

following HTML-Code should work; it doesn´t. I tested it
with Milestone 8 and 9 under Windows 95.

<html>
<head><title>CSS-Test</title></head>
<body>

<div style="position:absolute; top:20; left:40; visibility:hidden;" id="test">
Test
</div>

<script language="JavaScript">
<!--
div = document.getElementsByTagName("div");
div["test"].style.visibility = "visible";
//-->
</script>

</body>
</html>

If I leave out "visiblity:hidden;" I can freely switch the
visibility between "hidden" and "visible".

Sorry, but that´s all I know about that issue...

bye,

Maik Merten
Assignee: don → peterl
Component: Browser-General → Style System
Changing to style system.  I'm deciding whether to resolve this as a duplicate
of bug 12194 or the other way around.  I think this is the simpler test case...

Comment 2

18 years ago
*** Bug 12194 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Assignee: peterl → troy

Comment 3

18 years ago
Possible dupe of 10961?

Comment 4

18 years ago
I added code to SyncAndInvalidateView() and DidReflow() to make sure they do the
same thing as CreateViewForFrame() does.

Comment 5

18 years ago
That doesn't fix this bug, though. It looks to me like the styles are not
actually being changed.

I'm attaching a test case that tries to change the background-color of an
element during the onload handler, and that doesn't work either.

I don't know what this problem is, so I'm assigning this bug back to you

Updated

18 years ago
Assignee: troy → peterl

Comment 6

18 years ago
Created attachment 1873 [details]
example that sets background-color in onload handler

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

18 years ago
QA Contact: leger → chrisd

Comment 7

18 years ago
Updating QA Contact.

Updated

18 years ago
Status: RESOLVED → REOPENED

Comment 8

18 years ago
Using 12/2 build with Troy's test case, if color should change to yellow at
'body onload', it is not doing so. Reopening bug. If I am misunderstanding the
result, please resolve with explanation. Also, reassigning to Pierre.

Updated

18 years ago
Resolution: FIXED → ---
Assignee: peterl → pierre
Status: REOPENED → NEW
Really reassigning to Pierre...
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Whiteboard: [new]
Target Milestone: M14
(Assignee)

Comment 10

18 years ago
*** Bug 24093 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Blocks: 20226

Updated

18 years ago
Blocks: 18962
(Assignee)

Comment 11

18 years ago
Bug 23272 will be closed as dup. It contains an interesting testcase.
(Assignee)

Comment 12

18 years ago
*** Bug 23272 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 13

18 years ago
*** Bug 31299 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

18 years ago
Bug 32838 will be closed as dup. It contains an interesting testcase too.
(Assignee)

Comment 15

18 years ago
*** Bug 32838 has been marked as a duplicate of this bug. ***

Comment 16

18 years ago
Moving crufty m14-m15 bugs out to m16 for proper triage.
Target Milestone: M14 → M16
(Assignee)

Comment 17

18 years ago
*** Bug 27367 has been marked as a duplicate of this bug. ***

Comment 18

18 years ago
*** Bug 35357 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 19

18 years ago
The testcase from Troy is wrong. The JS property should be backgroundColor, not 
background-color.
(Assignee)

Comment 20

18 years ago
Created attachment 8065 [details]
example showing that the previous example is invalid
(Assignee)

Comment 21

18 years ago
The testcase from the reporter seems to work now...
(Assignee)

Comment 22

18 years ago
Created attachment 8066 [details]
testcase from the reporter

Updated

18 years ago
Target Milestone: M16 → M17

Comment 23

18 years ago
Adding nsbeta2 keyword since there are a lot of duplicates.
Keywords: nsbeta2
This should definitely be nsbeta2. Ability to hide/show elements from JS is 
critical for creating web app UIs using DHTML.

Comment 25

18 years ago
[nsbeta2+]
Whiteboard: [new] → [nsbeta2+] [new]
(Assignee)

Comment 26

18 years ago
So far, we have:
- Testcase from the reporter: WORKS NOW
- Testcase from Troy: INVALID
- Bug 12194: MISSING TESTCASE
- Bug 24093: WORKS NOW (the url changed; remove the "/design7")
- Bug 23272: INVALID (wrong browser-sniffing code; see the bug report)

We still need to check the other bugs closed as dups:
- Bug 31299
- Bug 32838
- Bug 27367
- Bug 35357

I sent a separate mail to David Baron asking him if he could retrieve the 
testcase from bug 12194.
(Assignee)

Comment 27

18 years ago
Bug 31299 was invalid too.
Three more bugs to go...
(Assignee)

Comment 28

18 years ago
The last three bugs were invalid too. This bug can be closed as Invalid.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → INVALID
I restored the testcase from bug 12194, but it crashes.  Filed bug 41246.

Comment 30

18 years ago
Marking VERIFED INVALID on:
- MacOS9 2000-06-01-20-M16 Commercial Build
- Linux6 2000-06-01-20-M16 Commercial Build
- Win98  2000-06-01-21-M16 Commercial Build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.