Closed Bug 1219416 Opened 5 years ago Closed 5 years ago

Display "Search" title when opening search preferences with the magnifying glass

Categories

(Firefox for Android :: Settings and Preferences, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 45
Tracking Status
firefox44 --- verified
firefox45 --- verified
b2g-v2.5 --- fixed
fennec 44+ ---

People

(Reporter: tynn, Assigned: tynn)

References

Details

Attachments

(1 file)

When opening search preferences with the magnifying glass, the title displayed shows the name of the build. Instead it should display "Search".
Flags: needinfo?(margaret.leibovic)
Attached patch bug1219416.patchSplinter Review
I couldn't verify it for preHC, but updateTitleForPrefsResource() should take care of it.
Flags: needinfo?(margaret.leibovic)
Attachment #8680229 - Flags: review?(margaret.leibovic)
Assignee: nobody → tynn.dev
Blocks: 1172083
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
See Also: 1172083
Comment on attachment 8680229 [details] [diff] [review]
bug1219416.patch

Review of attachment 8680229 [details] [diff] [review]:
-----------------------------------------------------------------

I was just working in this code, but I still find it confusing! This looks like the right thing to do. I also don't have a preHC device to test, so I can flag our QA team to help verify this once it lands.
Attachment #8680229 - Flags: review?(margaret.leibovic) → review+
Tracking 44 to match the bug this code landed in.
tracking-fennec: --- → 44+
Comment on attachment 8680229 [details] [diff] [review]
bug1219416.patch

Merge came early, so we need to uplift...

Approval Request Comment
[Feature/regressing bug #]: bug 1172083

[User impact if declined]: The search settings page will have the wrong title when opened from the quick search bar.

[Describe test coverage new/current, TreeHerder]: No automated test, just landed on fx-team.

[Risks and why]: Low-risk, small change to how we display titles on settings pages.

[String/UUID change made/needed]: none
Attachment #8680229 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/76627e2cb506
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 45
Comment on attachment 8680229 [details] [diff] [review]
bug1219416.patch

Fix looks simple enough and has been on Nightly for a few days. Let's uplift to Aurora44.
Attachment #8680229 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 1221513
No longer depends on: 1221513
Tapping the magnifying glass from the quick search bar opens the "Search" sub-menu from settings. "Search" is displayed as title.
Verified as fixed using:
Device: Xiaomi Mi i4 (Android 5.0.2)
Build: Firefox for Android 45.0a1 (2015-11-11)
Tapping the magnifying glass from the quick search bar opens the "Search" sub-menu from settings. "Search" is displayed as title.
Verified as fixed using:
Device: Moto X (Android 4.4)
Build: Firefox for Android 44.0a2 (2015-11-23)
You need to log in before you can comment on or make changes to this bug.