Closed Bug 1219709 Opened 5 years ago Closed 5 years ago

Handle syncing state on TV browser settings and toolbar UI

Categories

(Firefox OS Graveyard :: Sync, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.5 fixed)

RESOLVED FIXED
FxOS-S10 (30Oct)
Tracking Status
b2g-v2.5 --- fixed

People

(Reporter: ferjm, Assigned: ferjm)

References

Details

(Whiteboard: [partner-cherry-pick])

Attachments

(1 file)

Because we trigger a sync request during the boot up process, it is possible that the user opens the browser app while Sync is in syncing state. In that case, we won't be showing the proper UI (i.e. no signed in user in the toolbar and '{email}' in the settings menu).
Assignee: nobody → ferjmoreno
Blocks: fxos-sync
Priority: -- → P2
Target Milestone: --- → FxOS-S10 (30Oct)
Attachment #8681289 - Flags: review?(yliao)
Comment on attachment 8681289 [details] [review]
[gaia] ferjm:bug1219709.syncing.state.show.user.tv > mozilla-b2g:master

Thank you!
Attachment #8681289 - Flags: review?(yliao) → review+
Comment on attachment 8681289 [details] [review]
[gaia] ferjm:bug1219709.syncing.state.show.user.tv > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1194108
[User impact] if declined: A user will not know the current fx account sign in state when she opens the browser while the data is syncing.
[Testing completed]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=abdf98552ae6aab4585d08d015d4c60d4d285f58
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8681289 - Flags: approval-gaia-v2.5?
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [partner-cherry-pick]
Comment on attachment 8681289 [details] [review]
[gaia] ferjm:bug1219709.syncing.state.show.user.tv > mozilla-b2g:master

Approved for 2.5 uplift. 

Thanks
Attachment #8681289 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
You need to log in before you can comment on or make changes to this bug.