Closed Bug 1219918 Opened 5 years ago Closed 2 years ago

malformed xml error when checking for updates on nightly channel on Flame device

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: dietrich, Unassigned)

References

Details

STR:

1. flash latest base build
2. change channel to "nightly" and update
3. after update completes, check for updates

You'll see an error. Logcat:

I/Gecko   (  211): UpdatePrompt: Forcing update check
I/Gecko   (  211): *** AUS:SVC Checker: checkForUpdates, force: true
I/GeckoConsole(  211): AUS:SVC Checker: checkForUpdates, force: true
I/Gecko   (  211): *** AUS:SVC Checker:getUpdateURL - update URL: https://aus5.mozilla.org/update/5/B2G/44.0a1/20151023030241/flame/en-US/nightly/Boot2Gecko%202.5.0.0-prerelease%20(SDK%2019)/default/default/default/update.xml?force=1
I/GeckoConsole(  211): AUS:SVC Checker:getUpdateURL - update URL: https://aus5.mozilla.org/update/5/B2G/44.0a1/20151023030241/flame/en-US/nightly/Boot2Gecko%202.5.0.0-prerelease%20(SDK%2019)/default/default/default/update.xml?force=1
I/Gecko   (  211): *** AUS:SVC Checker:checkForUpdates - sending request to: https://aus5.mozilla.org/update/5/B2G/44.0a1/20151023030241/flame/en-US/nightly/Boot2Gecko%202.5.0.0-prerelease%20(SDK%2019)/default/default/default/update.xml?force=1
I/GeckoConsole(  211): AUS:SVC Checker:checkForUpdates - sending request to: https://aus5.mozilla.org/update/5/B2G/44.0a1/20151023030241/flame/en-US/nightly/Boot2Gecko%202.5.0.0-prerelease%20(SDK%2019)/default/default/default/update.xml?force=1
I/GeckoDump(  211): XXX FIXME : Got a mozContentEvent: force-update-check
W/GeckoConsole(  211): [JavaScript Warning: "This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1." {file: "https://m.facebook.com/openwebapp/manifest.webapp" line: 0}]
I/Gecko   (  211): *** AUS:SVC Checker:onError - request.status: 2153389949
I/GeckoConsole(  211): AUS:SVC Checker:onError - request.status: 2153389949
I/Gecko   (  211): *** AUS:SVC getStatusTextFromCode - transfer error: Update XML file malformed (200), default code: 200
I/GeckoConsole(  211): AUS:SVC getStatusTextFromCode - transfer error: Update XML file malformed (200), default code: 200
I/Gecko   (  211): UpdatePrompt: Setting gecko.updateStatus: check-error-2153389949
I/Gecko   (  211): *** AUS:SVC UpdateService:onError - error during background update. error code: -2141577347, status text: Update XML file malformed (200)
I/GeckoConsole(  211): AUS:SVC UpdateService:onError - error during background update. error code: -2141577347, status text: Update XML file malformed (200)
URL is showing a blank XML.  Not sure why.  I would have to investigate further.  This is the same issue we faced on aries yesterday.  I don't think I have time to investigate today.  Maybe next week?

<?xml version="1.0"?>
<updates>
</updates>
Flags: needinfo?(nhirata.bugzilla)
See Also: → 1220056
Ah.  figured it out : 
20151023030241 is the latest version, so no xml.

You're also on the nightly channel, not the nightly-latest.  If you change the URL with nightly to nightly-latest, you will get an update ( see https://wiki.mozilla.org/B2G/QA/Flame_OTA )

Chances are you may have hit Marcia's bug 1217490.  If you had it with nightly-latest, the FOTA would FOTA you back to nightly channel unless you set app.update.channel.backup to nightly-latest using webIDE.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(nhirata.bugzilla)
Resolution: --- → WORKSFORME
Er, why do we have nightly and nightly-latest? And why is a week old build the latest for a channel called "nightly"?!

We've got to get this sorted - no way any contributor will be able to make sense of it. I certainly cannot :)

I'm re-opening because changing the channel to "nightly-latest" (i've never had it on that channel before - first i've heard of it in fact) and then checking for updates still results in an error.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Because nightly is QA verified nightlies and nightly-latest is not QA verified.

It's broken today for a different reason than when it broke for you on 10/31.  10/31 was due to the gecko branching.
Also to note, it's one thing to have a nightly with a broken app on desktop machine, it's another thing to have a nightly that bricks your device.  that's why we QA qualify the builds for "nightly"
This currently occurs because the nightly channel was modified due to the aries, and the release that was used does not account for flame.
Flags: needinfo?(jlorenzo)
Flags: needinfo?(janx)
Yes, sorry we hijacked the "nightly" channel to get back some "dogfood" devices we lost (see bug 1224725). We expect to stop doing this next week in order to resume normal "nightly" channel activity. Sorry about the confusion.

By the way, this is the XML that nightly devices currently receive (no update):

https://aus5.mozilla.org/update/5/B2G/44.0a1/20151023030241/aries/en-US/nightly/Boot2Gecko%202.5.0.0-prerelease%20%28SDK%2019%29/default/default/default/update.xml?force=1

Not sure why this is considered "malformed" (maybe an "<update>" entry is expected?) anyway this problem will go away soon.
Depends on: 1224725
Flags: needinfo?(janx)
Discussed offline with Naoki. The problem is that JSON file [1] of the release doesn't include an "aries" entry. A workaround is to download the JSON file, edit it manually to include the aries entry and reupload it again. 

However, the issue will likely come again

[1] https://aus4-admin.mozilla.org/releases#B2G-mozilla-central-nightly-20151023030241
Flags: needinfo?(jlorenzo)
Actually I found that the buildid was also specified for that specific OTA build.

I think we'll just have to wait it out for a little longer and clean the mess up per bug 1224725.
The other portion is the talk of the b2g-ota or foxfood channels and making sure we're all on the same page of what we name it and what builds are suppose to be on there.  Hopefully this discussion happens tomorrow.
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 5 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.