Closed Bug 1220195 Opened 4 years ago Closed 4 years ago

WebIDE-installed add-ons don't appear in the add-on settings until Settings is restarted

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5?, b2g-master verified)

RESOLVED FIXED
blocking-b2g 2.5?
Tracking Status
b2g-master --- verified

People

(Reporter: mikehenrty, Assigned: scottwu)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1215546 +++

Bug 1215546 fixed this problem for Marketplace add-ons by listening to the 'downloadsuccess' event. However, this doesn't work for WebIDE since that event never fires. We'll need to figure out an alternative path here for WebIDE, since this is quite annoying for add-on developers.
Looks like this was caused by bug 1215546. Fair enough since fixing this for the user case comes before developer case.

Scott, do you want to have a look at this?
Blocks: 1215546
Flags: needinfo?(scwwu)
Sorry didn't test the patch with WebIDE when I fixed the user case.

I've fixed it and will submit a patch for review later.

Thanks for reporting this :)
Assignee: nobody → scwwu
Flags: needinfo?(scwwu)
Comment on attachment 8681847 [details] [review]
[gaia] scottwu:1220195-addons-dont-appear-WebIDE > mozilla-b2g:master

Fixed the issue caused by Bug 1215546. Added a check to see if it's installed via marketplace or WebIDE. Thanks!
Attachment #8681847 - Flags: review?(gasolin)
[Blocking Requested - why for this release]: annoy if not available for addon developers
blocking-b2g: --- → 2.5?
Comment on attachment 8681847 [details] [review]
[gaia] scottwu:1220195-addons-dont-appear-WebIDE > mozilla-b2g:master

Yura could you help review it?
Attachment #8681847 - Flags: review?(gasolin) → review?(yzenevich)
Comment on attachment 8681847 [details] [review]
[gaia] scottwu:1220195-addons-dont-appear-WebIDE > mozilla-b2g:master

Thanks, r+ with a couple of comments.
Attachment #8681847 - Flags: review?(yzenevich) → review+
Thanks for reviewing Yura!
I've changed the test both installing from WebIDE and Marketplace.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
This bug has been verified as pass on latest build of Flame kk v2.6 and Aries kk v2.6 by the STR in comment 0.

Actual result: The add-on which you add from WebIDE will appear in add-ons list immediately.

See attachment: Verified_Aries_v2.6.3gp
Reproduce rate: 0/10

Device: Flame kk v2.6 512mb (master) (Pass)
Build ID               20151110150205
Gaia Revision          c0482775b1526add626b170dd53a72d10bcaf07c
Gaia Date              2015-11-10 02:25:52
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc473fe5dc512c450634506f68cbacfb40a06a23
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151110.182433
Firmware Date          Tue Nov 10 18:24:47 EST 2015
Firmware Version        V18D V4
Bootloader             L1TC000118D0

Device: Aries kk v2.6(master) (Pass)
Build ID               20151110120047
Gaia Revision          c0482775b1526add626b170dd53a72d10bcaf07c
Gaia Date              2015-11-10 02:25:52
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc473fe5dc512c450634506f68cbacfb40a06a23
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151110.111927
Firmware Date          Tue Nov 10 11:19:35 UTC 2015
Bootloader             s1
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.