[Toaster] In LTR, text is right-aligned when notification created with dir="rtl"

RESOLVED FIXED in FxOS-S11 (13Nov)

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: autra, Assigned: autra)

Tracking

unspecified
FxOS-S11 (13Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
Created attachment 8681824 [details]
toaster_title_body_alignment.png

[Steps]
- put your phone in English
- connect your phone to the webIDE, with the System app
- create a new notification with a dir 'rtl', for example by executing
> new Notification('مسيبمن', {body: 'body', icon: 'http://icdn.pro/images/fr/1/u/1up-champignon-icone-9299-96.png', dir: 'rtl'})
in the console
- observe the toaster

[Expected]
- The title and body are left-aligned

[Actual]
- The title and body are right-aligned, see toaster_title_body_alignment.png
(Assignee)

Updated

3 years ago
Blocks: 1181944
(Assignee)

Updated

3 years ago
Assignee: nobody → augustin.trancart
Status: NEW → ASSIGNED
Created attachment 8681831 [details] [review]
[gaia] Phoxygen:bug1220563-toaster_alignment > mozilla-b2g:master
(Assignee)

Comment 2

3 years ago
Comment on attachment 8681831 [details] [review]
[gaia] Phoxygen:bug1220563-toaster_alignment > mozilla-b2g:master

Hi Etienne,

A quick patch to correct alignment in toaster. Apparently my patch in bug 1212329 missed this.
Attachment #8681831 - Flags: review?(etienne)
Attachment #8681831 - Flags: review?(etienne) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/d2342238a3c9c247fcbd2cb3a46dbb0499904efa
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S11 (13Nov)
(Assignee)

Comment 4

3 years ago
Comment on attachment 8681831 [details] [review]
[gaia] Phoxygen:bug1220563-toaster_alignment > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): none
[User impact] if declined: bad RTL experience for notifications
[Testing completed]: on flame
[Risk to taking this patch] (and alternatives if risky): Low, only css change, but should be uplifted AFTER bug 1219618
[String changes made]: none
Attachment #8681831 - Flags: approval-gaia-v2.5?
(Assignee)

Comment 5

3 years ago
Comment on attachment 8681831 [details] [review]
[gaia] Phoxygen:bug1220563-toaster_alignment > mozilla-b2g:master

Clearing uplift, already in 2.5.
Attachment #8681831 - Flags: approval-gaia-v2.5?
You need to log in before you can comment on or make changes to this bug.