Startup crash that takes SpringBoard down

RESOLVED DUPLICATE of bug 1238006

Status

()

RESOLVED DUPLICATE of bug 1238006
3 years ago
3 years ago

People

(Reporter: st3fan, Unassigned)

Tracking

unspecified
Other
iOS
Dependency tree / graph

Firefox Tracking Flags

(fxios1.3+)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
It’s just SpringBoard restarting.

Nov  1 10:09:54 iPhone-6 securityd[92] <Error>:  secTaskDiagnoseEntitlements MISSING keychain entitlements: no stored taskRef found
Nov  1 10:09:54 iPhone-6 amfid[550] <Error>:  SecTrustEvaluate  [leaf IssuerCommonName SubjectCommonName]
Nov  1 10:09:57 iPhone-6 com.apple.WebKit.WebContent[945] <Error>: CoreAnimation: failed to allocate IOSurface

<boom>
Do we appear in the log?
Doug, do you have more logs? Do you have crash reporting turned on in Firefox settings?
Flags: needinfo?(dougt)
tracking-fxios: ? → 1.2+
(Reporter)

Updated

3 years ago
tracking-fxios: 1.2+ → 1.3+
Created attachment 8687817 [details]
log1.txt

Build: Beta 1113
Device: iPhone 6 Plus (9.1)

Can't say what caused this, but SpringBoard is restarting every time I try to open Firefox.

I don't see any crash reports

https://www.youtube.com/watch?v=A8YKjHIk3NM
(Reporter)

Comment 4

3 years ago
Can you get the JetsamEvent-2015-11-16-105221.ips file via Settings -> Privacy -> Diagnostics/ It contains some more hints.

Updated

3 years ago
Flags: needinfo?(catalin.suciu)
Created attachment 8687962 [details]
JetsamEvent-2015-11-16-105221.ips.synced
Flags: needinfo?(catalin.suciu)
Catalin, is this still reproducible? Stefan mentioned on IRC that we will provide you with a build for the iPad to test (leave the iPad as is in the meantime please).
Flags: needinfo?(sarentz)
Flags: needinfo?(catalin.suciu)
Yes, I can reproduce on the configuration mentioned in comment #3. I didn't re-install or update Firefox on this device because I'm not sure that the issue will reproduce after that.
Flags: needinfo?(catalin.suciu)

Comment 8

3 years ago
no longer can reproduce.  i recall some warning in the log about a surface allocation failure.  Sorry.
Flags: needinfo?(dougt)
Created attachment 8691346 [details]
log1302

Logs from build 1302
With the local web server disabled, Firefox didn't crash. When re-enabling, Firefox crashed again.
After skipping session restore one time, I wasn't able to reproduce the crash again

Updated

3 years ago
Rank: 2
I've ran into this issue again on build 1308.

Updated

3 years ago
Duplicate of this bug: 1231539
(Reporter)

Comment 13

3 years ago
We need to get https://bugzilla.mozilla.org/show_bug.cgi?id=1232189 going so that we can take a look at the tabState that may be causing this.
Depends on: 1232189
Flags: needinfo?(sarentz)

Updated

3 years ago
Duplicate of this bug: 1233852

Updated

3 years ago
Duplicate of this bug: 1234269
There is a spike in users experiencing this on their iPhone with iOS 9.1 on SUMO.

Comment 17

3 years ago
If you need an active device that is experiencing this, I can provide logs or any details. Had to go back to using Chrome until this is fixed.
(In reply to Casey Johnson from comment #17)
> If you need an active device that is experiencing this, I can provide logs
> or any details. Had to go back to using Chrome until this is fixed.

Yes, please provide all logs. Please attach them to this bug.
Depends on: 1218836

Updated

3 years ago
See Also: → bug 1238006
(Reporter)

Comment 19

3 years ago
Duplicating this to 1238006 since all the recent discussion happened there.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1238006
You need to log in before you can comment on or make changes to this bug.