Notification toaster is redisplayed after reboot

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
9 months ago

People

(Reporter: aryx, Unassigned)

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

B2G 2.6 20151102150204 on Flame (v18D_nightly_v4 base image)

Rebooting with undismissed notifications still in the notification tray/screen will show the latest one again in a toast after a reboot.

Steps to reproduce:
1. Take screenshot (Volume down + Power).
2. Reboot the device.

Actual result:
Notification shown again on top.

Expected result:
No toast notification.
That is being done on purpose: we want notifications to be kept and displayed after reboot, except in some specific cases were it makes no sense.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Keeping them in the notification tray is something different than retriggering the toast which has already been shown before (e.g. when taking the screenshot or saving the logs). So why show them again as toast? Such an unimportant toast doesn't motivate to open the notification tray and discover more important ones.
(In reply to Sebastian H. [:aryx][:archaeopteryx] from comment #2)
> Keeping them in the notification tray is something different than
> retriggering the toast which has already been shown before (e.g. when taking
> the screenshot or saving the logs). So why show them again as toast? Such an
> unimportant toast doesn't motivate to open the notification tray and
> discover more important ones.

That's something UX should decide for.
Let's re-open this for UX consideration. I don't think we did this behavior on purpose.
Status: RESOLVED → REOPENED
Keywords: polish
Resolution: INVALID → ---
Whiteboard: [systemsfe]
Yes, I missed the point that the request was specifically about the toaster itself. I guess we always had that behavior but the changes to the boot code of the system app might have started to expose that: in the past, the toaster would have been displayed before that UI gets visible.
Blocks: 874364
Summary: Latest undismissed notification shown again after every restart/reboot → Notification toaster is redisplayed after reboot
Yes, and it's actually quite related to bug 1195233: because we use the same code path to show the notifications, everything happens as if that's new notifications :)
See Also: → bug 1195233

Comment 7

9 months ago
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.