Turn on e10s mochitest-gl on Windows 7

RESOLVED FIXED

Status

Release Engineering
General Automation
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jgriffin, Assigned: jgriffin)

Tracking

(Blocks: 1 bug)

unspecified
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

2 years ago
Latest try run shows this is green on both debug and opt:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=f439ce85793b
(Assignee)

Comment 1

2 years ago
Created attachment 8682504 [details] [diff] [review]
Enable mochitest-gl-e10s on Windows 7 on trunk,
Attachment #8682504 - Flags: review?(jmaher)
(Assignee)

Comment 2

2 years ago
Builders added:
+ Windows 7 32-bit b2g-inbound debug test mochitest-gl-e10s
+ Windows 7 32-bit b2g-inbound opt test mochitest-gl-e10s
+ Windows 7 32-bit b2g-inbound pgo test mochitest-gl-e10s
+ Windows 7 32-bit fx-team debug test mochitest-gl-e10s
+ Windows 7 32-bit fx-team opt test mochitest-gl-e10s
+ Windows 7 32-bit fx-team pgo test mochitest-gl-e10s
+ Windows 7 32-bit mozilla-central debug test mochitest-gl-e10s
+ Windows 7 32-bit mozilla-central opt test mochitest-gl-e10s
+ Windows 7 32-bit mozilla-central pgo test mochitest-gl-e10s
+ Windows 7 32-bit mozilla-inbound debug test mochitest-gl-e10s
+ Windows 7 32-bit mozilla-inbound opt test mochitest-gl-e10s
+ Windows 7 32-bit mozilla-inbound pgo test mochitest-gl-e10s
+ Windows 7 32-bit try debug test mochitest-gl-e10s
+ Windows 7 32-bit try opt test mochitest-gl-e10s
(Assignee)

Comment 3

2 years ago
Will need a Treeherder patch as well.
Comment on attachment 8682504 [details] [diff] [review]
Enable mochitest-gl-e10s on Windows 7 on trunk,

Review of attachment 8682504 [details] [diff] [review]:
-----------------------------------------------------------------

looks good, just one question- you can address it if necessary and r=me.

::: mozilla-tests/config.py
@@ +615,5 @@
> +        'use_mozharness': True,
> +        'script_path': 'scripts/desktop_unittest.py',
> +        'extra_args': ['--mochitest-suite', 'mochitest-gl', '--e10s'],
> +        'blob_upload': True,
> +        'script_maxtime': 12000,

do we need 12000 as the maxtime?  I would think 1800 (30 minutes) would be better suited.
Attachment #8682504 - Flags: review?(jmaher) → review+

Updated

2 years ago
Blocks: 984139
tracking-e10s: --- → +
(Assignee)

Comment 5

2 years ago
(In reply to Joel Maher (:jmaher) from comment #4)
> Comment on attachment 8682504 [details] [diff] [review]
> Enable mochitest-gl-e10s on Windows 7 on trunk,
> 
> Review of attachment 8682504 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> looks good, just one question- you can address it if necessary and r=me.
> 
> ::: mozilla-tests/config.py
> @@ +615,5 @@
> > +        'use_mozharness': True,
> > +        'script_path': 'scripts/desktop_unittest.py',
> > +        'extra_args': ['--mochitest-suite', 'mochitest-gl', '--e10s'],
> > +        'blob_upload': True,
> > +        'script_maxtime': 12000,
> 
> do we need 12000 as the maxtime?  I would think 1800 (30 minutes) would be
> better suited.

Good point; I copy/pasted that from the non-e10s version, but that maxtime seems way too long. I agree with 1800s.
(Assignee)

Updated

2 years ago
Depends on: 1221495
(Assignee)

Updated

2 years ago
Blocks: 1221499
(Assignee)

Updated

2 years ago
No longer blocks: 1221499
(Assignee)

Comment 6

2 years ago
Created attachment 8683628 [details] [diff] [review]
Enable mochitest-gl-e10s on Windows 7 on trunk,

Updated script_maxtime to 1800s
(Assignee)

Updated

2 years ago
Attachment #8682504 - Attachment is obsolete: true
(Assignee)

Comment 7

2 years ago
Comment on attachment 8683628 [details] [diff] [review]
Enable mochitest-gl-e10s on Windows 7 on trunk,

Carry r+ forward
Attachment #8683628 - Flags: review+
(Assignee)

Comment 8

2 years ago
Comment on attachment 8683628 [details] [diff] [review]
Enable mochitest-gl-e10s on Windows 7 on trunk,

https://hg.mozilla.org/build/buildbot-configs/rev/c209fe73999f
Attachment #8683628 - Flags: checked-in+
this is failing in production, we need to set the config properly, I ran into this issue whilst doing  the m-oth -> a11y, chrome*.  Here is the patch I used:
https://bug1211889.bmoattachments.org/attachment.cgi?id=8680242

in this case we would need a gl-e10s:
http://hg.mozilla.org/build/buildbot-configs/file/tip/mozilla-tests/config.py#l878

and for all the platforms we care about, right now that is windows 7.  I can pick this up shortly
Created attachment 8684952 [details] [diff] [review]
add a config file option to mochitest e10s gl for windows 7 only
Attachment #8684952 - Flags: review?(bugspam.Callek)

Updated

2 years ago
Attachment #8684952 - Flags: review?(bugspam.Callek) → review+
landed:
https://hg.mozilla.org/build/buildbot-configs/rev/ff6d9da53ad9
Attachment #8684952 - Flags: checked-in+
In production: https://hg.mozilla.org/build/buildbot-configs/rev/ff6d9da53ad9
(Assignee)

Comment 13

2 years ago
Looks like this is working now; thanks for the fix jmaher!
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.