Debug app title 'clock.gaiamobile.org' is briefly visible in the search bar when Alarm pop-up appears

RESOLVED FIXED in Firefox OS master

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Marty, Assigned: albertopq)

Tracking

({regression})

unspecified
2.6 S1 - 11/20
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-v2.5 affected, b2g-master verified)

Details

(Whiteboard: [2.6-Daily-Testing][Spark][systemsfe])

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

2 years ago
Created attachment 8682805 [details]
Clock-Screenshot.png

Description:
When an alarm is triggered, the 

Repro Steps:
1) Update a Aries to 20151103140850
2) Open the Clock app and set an alarm to ring in 1 minute.
3) Watch the Search field of the Status Bar when the alarm is triggered.

Actual:
'clock.gaiamobile.org' is visible in the search bar when the alarm is triggered

Expected:
Debug text is not visible in the search bar.

Environmental Variables:
Device: Aries 2.6
Build ID: 20151103140850
Gaia: 06de78d2c61c084956640c480280ba518b2fe29f
Gecko: 59a6ad6a921f4809dfc37d943d765300c65721e5
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 10/10
See attached: Screenshot, Logcat
(Reporter)

Comment 1

2 years ago
This issue DOES occur on Flame 2.6 and 2.5 builds.
'clock.gaiamobile.org' is visible in the search bar when the alarm is triggered

Environmental Variables:
Device: Flame 2.6
BuildID: 20151103030244
Gaia: 06de78d2c61c084956640c480280ba518b2fe29f
Gecko: bb4d614a0b09bcb9738c151dccfcd9b3857a6a7c
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20151103004501
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: 4e0955369a51850f2982087145ac5c2df257ffe9
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

******************************************

This issue does NOT occur on Flame 2.2 builds.

Environmental Variables:
Device: Flame 2.5
BuildID: 20151103004501
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: 4e0955369a51850f2982087145ac5c2df257ffe9
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Reporter)

Comment 2

2 years ago
Created attachment 8682807 [details]
logcat_clock-popup.txt
(Reporter)

Comment 3

2 years ago
Description:
When an alarm is triggered, the search field in the status bar will briefly show 'clock.gaiamobile.org' as the pop-up appears.
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage?]
QA Contact: pcheng
Seems minor not nominating to block on this.
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
b2g inbound regression window:

Last Working
Device: Flame
BuildID: 20150717080801
Gaia: 8c009877aff6b8b2f4a60756e2d09c0182393721
Gecko: 5e33f87ac681
Version: 42.0a1
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken
Device: Flame
BuildID: 20150717080902
Gaia: 8c009877aff6b8b2f4a60756e2d09c0182393721
Gecko: c1bae5ba297f
Version: 42.0a1
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=5e33f87ac681&tochange=c1bae5ba297f

This issue is likely caused by changes made in bug 1183301.
Blocks: 1183301
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Alastor this issue seems to be caused by the changes for bug 1183301.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(alwu)
Duplicate of this bug: 1221346
Hi, Jayme,
My patch doesn't cause this behavior, it's just stop throwing the exception.
I think this issue should be caused by other changes.
Flags: needinfo?(alwu)
NI Alberto to take a look because according to a similar bug 1184672 comment 6, the fact that these strings display at all appears to be due to bug 1177477.
Flags: needinfo?(apastor)
(Assignee)

Comment 10

2 years ago
I don't think bug 1177477 has nothing to do. It probably comes from the Pinning the Web work. I'll take a look! Thanks!
Assignee: nobody → apastor
Flags: needinfo?(apastor)

Comment 11

2 years ago
Created attachment 8685403 [details] [review]
[gaia] albertopq:1221339-clock-header > mozilla-b2g:master
(Assignee)

Comment 12

2 years ago
:piwei, could you please confirm that it get's fixed by the attached patch? Thanks!
Flags: needinfo?(pcheng)
Also adding qawanted for this task.
Keywords: qawanted
This patch does fix this bug as well as bug 1221346 on Flame and Aries. Everything looks good. Thanks for looking into this and fixing it.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pcheng)
Flags: needinfo?(jmercado)
Flags: needinfo?(apastor)
Keywords: qawanted
(Assignee)

Comment 15

2 years ago
Comment on attachment 8685403 [details] [review]
[gaia] albertopq:1221339-clock-header > mozilla-b2g:master

Quick and simple review? Thanks!
Flags: needinfo?(apastor)
Attachment #8685403 - Flags: review?(mhenretty)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Whiteboard: [2.6-Daily-Testing][Spark] → [2.6-Daily-Testing][Spark][systemsfe]
Target Milestone: --- → 2.6 S1 - 11/20
Comment on attachment 8685403 [details] [review]
[gaia] albertopq:1221339-clock-header > mozilla-b2g:master

I would love to see a test for this, but the code looks good.
Attachment #8685403 - Flags: review?(mhenretty) → review+
(Assignee)

Comment 17

2 years ago
I would love to as well, but given the racy nature of this bug, I didn't find a reliable way of testing it. Any suggestion?

Thanks!
Flags: needinfo?(mhenretty)
Hmmm, yeah that's a tough one. Off the top of my head, we could fire an alarm (here is an example of how [1]), and then do a waitForElement on the appTitle with have the value of "clock.gaiamobile.org", and pass the test if this timesout, but fail the test if the waitForElement works. In the past we've talked about implementing a client.helper.makeSureElementWontAppear or something, but it never got very far.

1.) apps/clock/test/marionette/alarm_test.js
Flags: needinfo?(mhenretty)
If you think this test is not worth the effort, I'm ok with just landing this fix.
(Assignee)

Comment 20

2 years ago
I spent some time yesterday (and today) trying to add a test, but there is not a moment in which the appWindow.attentionWindow .chrome visibility is not hidden (in master). It seems it doesn't have time to get that value before the 'active' class is added. I'm going to go ahead and merge it, as it seems to me that is not worthy spending so much time on the test. Sorry!
(Assignee)

Comment 21

2 years ago
master: https://github.com/mozilla-b2g/gaia/commit/a515fc4198d45a203d1f48b79e9c53a3be98f0e8
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Flame KK 2.6 by the STR in comment 0.

Actual results: Debug app title 'clock.gaiamobile.org' / 'bluetooth.gaiamobile.org' is no longer visible in the search bar when Alarm pop-up appears / Bluetooth pair dialog appears.

See attachment: verified_Flame_v2.6.3gp
Reproduce rate: 0/10


Device: Flame KK v2.6 512mb (master)(Pass)
Build ID               20151115150212
Gaia Revision          e8c15ae4e5324a210000ee0a869a962aa542009f
Gaia Date              2015-11-13 00:10:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7cd2d806bd069c0260ff73f023ac85f892b863bf
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151115.184416
Firmware Date          Sun Nov 15 18:44:31 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Note: 
I can't verify Aries KK v2.6(master) because there is no the latest AriesKK v2.6(master) build now, but I will verify it once it has the latest AriesKK v2.6(master) build.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-master: affected → verified
Created attachment 8687793 [details]
verified_Flame_v2.6.3gp

Comment 24

2 years ago
skip_this_one
Hi Alberto,

    This bug is not fixed on the latest build of Flame KK v2.6 and Aries KK 2.6 by the STR in comment 0, but it is fixed on Flame Build ID 20151115150212 as mentioned in comment 22. Could you please help to check again?  Thank you very much.


------------------------------------------------------------------------------------------------
Actual results: Debug app title 'clock.gaiamobile.org' / 'bluetooth.gaiamobile.org' is visible in the search bar for a second when Alarm pop-up appears / Bluetooth pair dialog appears.

See attachments: verify_fail_Aries_v2.6.3gp(at 00:22~00:23) and logcat_2218.txt
Reproduce rate: 6/6


Device: Flame KK v2.6 512mb (master)(Fail)
Build ID               20151117150203
Gaia Revision          28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5
Gaia Date              2015-11-17 07:35:12
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8c3a0b58fd51c02c8aca138b0da58445becb037f
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151117.183602
Firmware Date          Tue Nov 17 18:36:15 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.6 (master)(Fail)
Build ID               20151117222127
Gaia Revision          28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5
Gaia Date              2015-11-17 07:35:12
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8c3a0b58fd51c02c8aca138b0da58445becb037f
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151117.214032
Firmware Date          Tue Nov 17 21:40:40 UTC 2015
Bootloader             s1
status-b2g-master: verified → fixed
Flags: needinfo?(apastor)
Created attachment 8688787 [details]
logcat_2218.txt
Created attachment 8688788 [details]
verify_fail_Aries_v2.6.3gp
This bug can be repro again now, maybe it's due to Bug 1224628. I will verify this bug once Bug 1224628 is fixed.
This bug has been verified as "pass" on the latest build of Aries KK 2.6 by the STR in comment 0.

Actual results: Debug app title 'clock.gaiamobile.org' / 'bluetooth.gaiamobile.org' is no longer visible in the search bar when Alarm pop-up appears / Bluetooth pair dialog appears.

See above attachment: "verified_Flame_v2.6.3gp"
Reproduce rate: 0/10

Device: Aries KK 2.6 (master) (Pass)
Build ID               20151118150439
Gaia Revision          cba7e4b86361af31b153cfebaf99900e0b860f7b
Gaia Date              2015-11-18 09:45:49
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1d6155d7e6c91fa5ec1ef6927f3d3a044187896d
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151118.142334
Firmware Date          Wed Nov 18 14:23:42 UTC 2015
Bootloader             s1
status-b2g-master: fixed → verified
Flags: needinfo?(apastor)
Attachment #8688788 - Attachment is obsolete: true
Attachment #8688787 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.