[TV Browser] Failed to go back to one-up level after tapping the Back button in Bookmarks list

VERIFIED FIXED in Firefox OS v2.5

Status

Firefox OS
Gaia::TV::Browser
P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: cynthiatang, Assigned: danhuang)

Tracking

unspecified
FxOS-S11 (13Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8682924 [details]
[TV]FirefoxAccount_v0.5

Commit f17421e9a23b9dbd88c41347f1b9c442a97f48e0
Merge: 06de78d e7dd557
Author: gasolin <gasolin@gmail.com>
Date:   Tue Nov 3 13:37:26 2015 +0800

STR:
 1. Launch Browser
 2. Sign in to Sync
 3. Go to "Show your bookmarks"
 4. Select a site in your bookmarks
 4. Press Back on the remote control 
    (Press ESC key on the physical keyboard)

Expected Result:
 - It will go back to one-up level
 - Please refer [TV]FirefoxAccount_v0.5, page 11

Actual Result:
 - Nothing happens
(Reporter)

Updated

3 years ago
QA Whiteboard: [COM=TV Firefox Account]
Side note: pressing back space key closes the bookmarks menu. Not sure if that's expected. YiFan, this seems to be another key navigation issue, could you take it, please? Thanks!
Blocks: 824026
Flags: needinfo?(yliao)
Priority: -- → P3
Target Milestone: --- → FxOS-S11 (13Nov)
Thanks! Dan please add the escape key handler in the smart list.
Assignee: nobody → dhuang
Status: NEW → ASSIGNED
Flags: needinfo?(yliao)
(Assignee)

Updated

3 years ago
Whiteboard: [ft:conndevices] → [ft:conndevices][partner-cherry-pick]
Created attachment 8687024 [details] [review]
[gaia] danhuang1202:1221420_back_button_support_in_smartList > mozilla-b2g:master
(Assignee)

Comment 4

3 years ago
Comment on attachment 8687024 [details] [review]
[gaia] danhuang1202:1221420_back_button_support_in_smartList > mozilla-b2g:master

Hi Yi-fan, please help review. This patch add escape key support in smartList. Thanks.
Attachment #8687024 - Flags: review?(yliao)

Updated

3 years ago
Attachment #8687024 - Flags: review?(yliao) → review?(selee)
Comment on attachment 8687024 [details] [review]
[gaia] danhuang1202:1221420_back_button_support_in_smartList > mozilla-b2g:master

LGTM! I leave some comments for the nits. Please fix them before landing. Thanks for the effort.
Attachment #8687024 - Flags: review?(selee) → review+
The bug # in PR's comment is incorrect. Please fix the comment in your PR. Thanks.
Flags: needinfo?(dhuang)

Updated

3 years ago
Priority: P3 → P1
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1227041
(Assignee)

Comment 8

3 years ago
revise commit log to 'Bug 1221427  - Support ecape key in smartlist. r=seanlee'
Flags: needinfo?(dhuang)
(Assignee)

Comment 9

3 years ago
Thanks for the review.
Merge in master: https://github.com/mozilla-b2g/gaia/commit/3f3637aede6a59d8f184305f34c4da0830c8fe5a
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

3 years ago
Comment on attachment 8687024 [details] [review]
[gaia] danhuang1202:1221420_back_button_support_in_smartList > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 824026
[User impact] if declined: the back button couldn't work in remote control.
[Testing completed]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=b6aac7aa647d6f65c7634e3946b77e600613f5a3
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: None
Attachment #8687024 - Flags: approval-gaia-v2.5?

Updated

3 years ago
blocking-b2g: --- → 2.5+
status-b2g-v2.5: --- → affected
status-b2g-master: --- → fixed

Comment 11

3 years ago
Comment on attachment 8687024 [details] [review]
[gaia] danhuang1202:1221420_back_button_support_in_smartList > mozilla-b2g:master

Approve for TV Browser 2.5
Attachment #8687024 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
(Reporter)

Comment 13

3 years ago
Verified.

=======  Passed in Master branch  ==================== 
commit ff662257263e9d71f8202d9d61a1b2035944e346
Merge: af7fe55 ae5cbee
Author: Johan Lorenzo <jlorenzo@mozilla.com>
Date:   Fri Dec 4 12:26:37 2015 +0100

=======  Passed in v2.5 branch ==================== 
Commit 2d54c29f429bed790b5d8284633812dc2b782518
Author: Fischer.json <foxbrush@Fischerjsons-MacBook-Pro.local>
Date:   Mon Nov 30 15:06:13 2015 +0800
Status: RESOLVED → VERIFIED
(Reporter)

Updated

3 years ago
status-b2g-v2.5: fixed → verified
status-b2g-master: fixed → verified
You need to log in before you can comment on or make changes to this bug.