Closed Bug 1222334 Opened 6 years ago Closed 6 years ago

[Browser]The "Pin" page will stay above primary layer.

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.5 verified, b2g-master verified)

VERIFIED FIXED
2.6 S1 - 11/20
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- verified
b2g-master --- verified

People

(Reporter: wangxin, Assigned: mikehenrty)

References

()

Details

(Whiteboard: [systemsfe])

Attachments

(6 files)

[1.Description]:
[Aries KK v2.6][Flame KK v2.5&v2.6][Browser]When user is in "Pin" page, try to invoke "Settings" in notification page or invoke "Cameara" in lockscreen, the "Pin" page will stay above primary layer.
See log:"logcat_2153.txt"
See video:"Aries_v2.5.3gp"
Found time: 21:53

[2.Testing Steps]: 
1. Open a website by "Browser".
2. Press "Menu"->"Pin".
3. When "Pin" page pops up, Press "Power" key.
4. Press "Power" again.
5. Try to invoke "Camera" on lockscreen.

[3.Expected Result]: 
4. The page will load to "Settings" page, and the "Pin" page will disappear.

[4.Actual Result]: 
5. You can see the "Pin" page display above Camera view.

[5.Reproduction build]: 
Flame KK v2.6 (512mb master)(affected):
Build ID               20151105150203
Gaia Revision          f39a7a827c0c0f48087ff3ead94f61ae22523919
Gaia Date              2015-11-05 18:52:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dae6c2b8fef8a2f504baab5dae7ccd59d57a1d9d
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151105.182857
Firmware Date          Thu Nov  5 18:29:10 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Aries KK v2.6(Affected):

Build ID               20151105235624

Gaia Revision          f39a7a827c0c0f48087ff3ead94f61ae22523919

Gaia Date              2015-11-05 18:52:32

Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dae6c2b8fef8a2f504baab5dae7ccd59d57a1d9d
Gecko 
Version          45.0a1

Device Name            aries

Firmware(Release)      4.4.2

Firmware(Incremental)  eng.worker.20151105.231433

Firmware Date          Thu Nov  5 23:14:41 UTC 2015

Bootloader             s1

Flame KK v2.5(512m)(affected):
Build ID               20151105004500
Gaia Revision          47da49f8206788d70d834c3a63d9245d50c89103
Gaia Date              2015-11-03 21:48:23
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/5c9fd135d4309239794126f1942d6e7aa8b3579c
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151105.043012
Firmware Date          Thu Nov  5 04:30:24 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free test

[8. Note]:
v2.2 not support Pin page, So I can not verified this bug on Flame v2.2.
Attached image 11.png
Moreover, if user continues to operate based on the bug, such as tap "pin site" after STR 5, the rocket icon with naming camera will appear on the homescreen, and, the icon can't be removed unless user resets device. Same issue also occurs on phone app, calendar app.....
Please see attachment: 11.png and logcat1.txt
[Blocking Requested - why for this release]:
In view of comment 2, nominate the bug.
blocking-b2g: --- → 2.6?
Hi Alison,

Could you help to dispatch this bug? I think the bug can cause a serious problem(see comment 2).
Thanks for your help :)
Flags: needinfo?(ashiue)
Hi Gregor,

Could you please dispatch this issue to suitable person to help check? Thank you.
QA Whiteboard: [COM=Pin the Web]
Flags: needinfo?(ashiue) → needinfo?(anygregor)
Whiteboard: [systemsfe]
[Blocking Requested - why for this release]:
Suggest to fix this issue also in v2.5
blocking-b2g: 2.6? → 2.5?
Flags: needinfo?(anygregor) → needinfo?(mhenretty)
Assignee: nobody → mhenretty
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(mhenretty)
Target Milestone: --- → 2.6 S1 - 11/20
Comment on attachment 8688525 [details] [review]
[gaia] mikehenrty:bug-1222334-close-pin-dialog-when-app-closes > mozilla-b2g:master

Etienne, Alberto and Guillaume are on PTO and this is 2.5+. Would you mind having a look?
Attachment #8688525 - Flags: review?(etienne)
Comment on attachment 8688525 [details] [review]
[gaia] mikehenrty:bug-1222334-close-pin-dialog-when-app-closes > mozilla-b2g:master

Nice!
Attachment #8688525 - Flags: review?(etienne) → review+
master: https://github.com/mozilla-b2g/gaia/commit/1445afe964bbae5d04a763426c16e5aa0f20f8eb
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8688525 [details] [review]
[gaia] mikehenrty:bug-1222334-close-pin-dialog-when-app-closes > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Not a regression, this was always a bug in our implementation of the pinning dialog.

[User impact] if declined:
Poor UX when user attempts to switch app which in the middle of pinning a page. user can get stuck in a half-usable state.

[Testing completed]:
Manually tested. Added integration test for protection.

[Risk to taking this patch] (and alternatives if risky):
The risk is to the pin dialog, but it only really adds closing functionality so at the very least it shouldn't have any catastrophic failures.

[String changes made]:none
Attachment #8688525 - Flags: approval-gaia-v2.5?
Comment on attachment 8688525 [details] [review]
[gaia] mikehenrty:bug-1222334-close-pin-dialog-when-app-closes > mozilla-b2g:master

Approved for 2.5 uplift. 

Thanks
Attachment #8688525 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
This issue has been verified as fixed on Aries and Flame 2.6

The camera app is invoke properly and does not appear behind the pin the web page.

Device: Aries 2.6
Build ID: 20151120133504
Gaia: 94a821b49f4dca3f9321cd80e13c44c4a6696952
Gecko: ec628289d8b4ed310463a0729c3e60a7798dfcac
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: Flame 2.6 (Full Flash)(KK)(512mb)
BuildID: 20151120030231
Gaia: 94a821b49f4dca3f9321cd80e13c44c4a6696952
Gecko: 3835b568092ae3b71adc931d24928670ad7141a7
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Pin the Web] → [COM=Pin the Web][QAnalyst-Triage?]
Flags: needinfo?(jmercado)
QA Whiteboard: [COM=Pin the Web][QAnalyst-Triage?] → [COM=Pin the Web][QAnalyst-Triage+]
Flags: needinfo?(jmercado)
This bug has been verified as "pass" on the latest build of Aries KK v2.5 and Flame KK v2.5 by the STR in comment 0.
Actual results: The camera app is invoke properly and does not appear behind the pin the web page.
See attchement: Flame_KK_v2.5.3GP
Occurrence rate: 0/10

Device: Flame KK v2.5 512mb (pass)
Build ID               20151123163948
Gaia Revision          5839f17dedc757947c9531dc0d66c3c49119f5ea
Gaia Date              2015-11-20 22:47:58
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/3a45ca93dd447e046baa2c7590f60ae008e438f8
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151123.155405
Firmware Date          Mon Nov 23 15:54:14 UTC 2015
Firmware Version        V18D  V4
Bootloader             L1TC000118D0

Device: Aries KK v2.5 (pass)
Build ID               20151123164502
Gaia Revision          5839f17dedc757947c9531dc0d66c3c49119f5ea
Gaia Date              2015-11-20 22:47:58
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/3a45ca93dd447e046baa2c7590f60ae008e438f8
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151123.155500
Firmware Date          Mon Nov 23 15:55:07 UTC 2015
Bootloader             s1
QA Whiteboard: [COM=Pin the Web][QAnalyst-Triage+] → [COM=Pin the Web][QAnalyst-Triage+][MGSEI-Triage+]
Flags: in-moztrap+
See Also: → 1231268
You need to log in before you can comment on or make changes to this bug.