Strange invalid suggestion with unified complete

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: dqeswn, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
When I type something with whitespaces, meaning more than one word. the unified complete shows wikipedia (en) as the first auto-highlighted result. This is strange because I have browser.urlbar.suggest.searches;false. I also have keyword.enabled;false.

When I press enter I get an invalid address screen.

If I just type something without spaces I don't get this. But http://whateverItyped is suggested, and I get a host not found, or a page loaded if it's an actual url. Which I guess is correct behavior.

As for why I get wikipedia suggested I'm not sure. I haven't used the searchbar for several years, and I have it removed from the GUI.
(In reply to avada from comment #0)
> As for why I get wikipedia suggested I'm not sure. I haven't used the
> searchbar for several years, and I have it removed from the GUI.

is wikipedia set as your default search engine in preferences?

I suspect the fact is that a single word may be interpreted as an host. so if you type a single word and have keyword.enabled;false, we'll think it may be a host, and try to load it. But, as soon as you add a space, it's clearly not an host. What is it?
The only things we can do in that case is:
1. nothing
2. search for those words

1. would be sort of crazy, you typed and pressed enter... nothing happens?

Note that the behavior should be the same without unified complete, if you type multiple words with keyword.enabled;false, it should try to run a search (even if it doesn't show the "search with" line).
keyword.enabled is only valid for things that look like a host, so single strings, afaik.

As such, I'd be prone to mark the bug as invalid.
Does this make sense?
(Reporter)

Comment 2

3 years ago
It is set as the default search engine

The behavior is almost the same: Invalid url error page.
Except that the unified complete shows the search with wikipedia text while typing.

I found something more:

-Pressing enter results in loading the invalid url error page.
-Clicking on it loads the wikipedia search.

So clearly disabling the suggest search feature fails in this case. It's sort of half disabled.

In my opinion loading the invalid url is the correct behavior since search suggestions are disabled. Certainly not this hybrid behavior.
(In reply to avada from comment #2)
> So clearly disabling the suggest search feature fails in this case. It's
> sort of half disabled.

Search suggestions have nothing to do with the first "Search with:" entry in the location bar, search suggestions are only about suggestions coming from the remote search engine. The search with: entry is just telling you pressing enter will run a search for the text you entered.

(In reply to avada from comment #2)
> It is set as the default search engine
> 
> The behavior is almost the same: Invalid url error page.
> Except that the unified complete shows the search with wikipedia text while
> typing.

So it shows "Search with wikipedia" but if you press Enter, it loads an invalid url error page?

This looks wrong, the line should be consistent with the behavior.
(Reporter)

Comment 4

2 years ago
I did a test with latest nightly. This bugged behavior is still present.

I also get an infinite throbber.
Version: 43 Branch → Trunk
(Reporter)

Updated

2 years ago
Blocks: 1071461
Component: Places → Location Bar
Product: Toolkit → Firefox
(Reporter)

Updated

2 years ago
See Also: → bug 1313843
Resolved per bug 1313843 comment 5:

(In reply to avada from comment #5)
> I can't reproduce it either, neither Bug 1222378. So I guess they were
> fixed, perhaps in bug 1318070.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.