"Change Home Screen" shows both the old and new homescreens with the same name

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: emorley, Assigned: iann_bugzilla)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
>> Feature Request Summary:
"Change Home Screen" shows both the old and new homescreens with the same name

>> Description of feature, or problem to be solved
Using the Z3C foxfooding device with the latest FOTA/OTA installed (build number: eng.naoki.20151007.074137, build identifier 20151023101519).

STR:
1) Open settings
2) Open homescreen
3) Open "Change Home Screen"

Expected:
Each homescreen listed has a different name, and one that implies how it differs from the others.

Actual:
Two entries both listed "Homescreen". Both also have the same description.
I have not installed any additional homescreens myself; I presume one is the old homescreen and the other is the new one
(Reporter)

Updated

3 years ago
Blocks: 1191745

Updated

3 years ago
No longer blocks: 1191745

Comment 1

3 years ago
Ed, I see two home screens - 'Legacy Home Screen' and 'Default Home Screen'. Is this not what you see? It could be the build you're running is missing the bug that actually made the switch and renamed the old home screen.
Flags: needinfo?(emorley)
I see the same thing using en-GB language, it will be fixed once the en-GB localization will be completed. We can’t change entity name in manifest files, so the old translations are still used.

We don’t usually file bugs for incomplete translations, but you can move this bug under Mozilla Localizations > English GB component to let the team know.
(Reporter)

Comment 3

3 years ago
Yeah my phone is in en-gb, so I guess that explains it.

That said, it seems like a bug to show a broken translation rather than the en-us if the translation was incomplete. Is this a result of not using a new string name (eg fooBar -> fooBar2) when the new homescreen landed? I thought that was standard practice when strings were changed?
Flags: needinfo?(emorley)
(In reply to Ed Morley [:emorley] from comment #3)
> Yeah my phone is in en-gb, so I guess that explains it.
> 
> That said, it seems like a bug to show a broken translation rather than the
> en-us if the translation was incomplete. Is this a result of not using a new
> string name (eg fooBar -> fooBar2) when the new homescreen landed? I thought
> that was standard practice when strings were changed?

Yes, entity name must be changed every time a string is updated, except when the code does not allow us to to so, which is the case here.

In that case, a message is usually sent to dev.l10n mailing list. Maybe we did it for this string, but I can’t remember. Flod, should we send a recap message with all the changes in .manifest files for 2.5?
Flags: needinfo?(francesco.lodolo)
Somehow this slipped through the cracks. I asked Théo to send a reminder to dev-l10n about this change, and to add a specific test for l10n testing. Filing bugs at this point is not useful since most localizations are not up to date, and falling back to the existing value is technically correct.
Flags: needinfo?(francesco.lodolo)
(Reporter)

Comment 6

3 years ago
(In reply to Francesco Lodolo [:flod] from comment #5)
> Filing bugs at this point is not useful 

In the sense that the foxfood participants have been given a device and asked to file issues, and when filing those issues they have no idea as to the cause, I believe filing bugs is useful.

However if you mean "filing additional bugs for other languages" and/or keeping this bug in a Firefox OS component (as opposed to wherever missing translations get filed), then I agree.
(In reply to Ed Morley [:emorley] from comment #6)
> However if you mean "filing additional bugs for other languages" and/or
> keeping this bug in a Firefox OS component (as opposed to wherever missing
> translations get filed), then I agree.

I meant filing bugs for this issue in other locales: it's too early, given that most of them haven't started working on 2.5 yet (string freeze was 4 days ago). 

I would also move this one to en-GB, since it's not a bug in Homescreen but in that localization, and at some point they'll have to make sure it's fixed.

I don't have any details on the foxfooding program, but I think some guidelines, at least for filing localization bugs, would be useful.
Sent a note here https://groups.google.com/d/msg/mozilla.dev.l10n/uzGHf-zlHjE/A8NRHUh8BgAJ

I agree with flod, let’s move this one to en-GB component to make sure it’s in their radar.
Assignee: nobody → moz_en-gb
Component: Gaia::Homescreen → en-GB / English (United Kingdom)
Product: Firefox OS → Mozilla Localizations
QA Contact: moz_en-gb
(Reporter)

Comment 9

3 years ago
Thank you for moving to the correct location :-)

(In reply to Francesco Lodolo [:flod] from comment #7)
> I meant filing bugs for this issue in other locales: it's too early, given
> that most of them haven't started working on 2.5 yet (string freeze was 4
> days ago). 

Ah ok.

> I don't have any details on the foxfooding program, but I think some
> guidelines, at least for filing localization bugs, would be useful.

I agree some guidelines would be useful in general, though in this case it wasn't clear this was a localisation issue (for all I knew, the old and new homescreens had just been given the same name in en-us too).
(Assignee)

Comment 10

3 years ago
I have updated the strings via Pontoon, hopefully they will flow through okay.
I'm just going through https://transvision.mozfr.org/gaia/#changed_english to see what else needs updating.
(Assignee)

Comment 11

3 years ago
(In reply to Ian Neal from comment #10)
> I have updated the strings via Pontoon, hopefully they will flow through
> okay.
> I'm just going through https://transvision.mozfr.org/gaia/#changed_english
> to see what else needs updating.

Finished updating rest of those strings.
Assignee: moz_en-gb → iann_bugzilla
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

3 years ago
Many thanks :-)

Comment 13

3 years ago
Hi, Lancy,

Please assign a tester to verify this bug.
We need to do side-by-side comparison between 2.2 and 2.5, and transvision is better tool to verify it.
- https://transvision.mozfr.org/gaia/#changed_english

Thank you.
Flags: needinfo?(yulan.zhu)
Created attachment 8690749 [details]
Portuguese from Brazil&Slovenian.png

Hi William,
This issue is verified as "Pass" on latest v2.5 and master build in English, Arabic, Czech, Spanish, Serbian Cyrillic, Romanian, Portuguese from Portugal, Dutch, Swedish, Urdu, Japanese, Traditional Chinese, Bengali from Bangladesh, Bengali from India, Slovak, Songhay, Albanian, Bosnian and Basque languages, "Legacy Home Screen" and "Default Home Screen" are shown in "Change Home Screen" view and translated to local language.

But in Portuguese from Brazil and Slovenian languages, "Change Home Screen" shows both the old and new homescreens with the same name on v2.5&master build.

See attachment:Portuguese from Brazil&Slovenian.png

FlameKK 2.5 512mb build:
Build ID               20151119161153
Gaia Revision          28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5
Gaia Date              2015-11-17 07:35:12
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/497118efc1414c2825a8bd17b38721888c3875ca
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151119.152146
Firmware Date          Thu Nov 19 15:21:56 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

FlameKK master 512mb build:
Build ID               20151119224634
Gaia Revision          94a821b49f4dca3f9321cd80e13c44c4a6696952
Gaia Date              2015-11-19 15:35:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc325db44f6f8a58604d60b746c140e73f3d8216
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151119.220436
Firmware Date          Thu Nov 19 22:04:46 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

AriesKK v2.5 build:
Build ID               20151119161838
Gaia Revision          28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5
Gaia Date              2015-11-17 07:35:12
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/497118efc1414c2825a8bd17b38721888c3875ca
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151119.152025
Firmware Date          Thu Nov 19 15:20:33 UTC 2015
Bootloader             s1

AriesKK master build:
Build ID               20151120061630
Gaia Revision          94a821b49f4dca3f9321cd80e13c44c4a6696952
Gaia Date              2015-11-19 15:35:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3835b568092ae3b71adc931d24928670ad7141a7
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151120.052332
Firmware Date          Fri Nov 20 05:23:39 UTC 2015
Bootloader             s1

Please contact me if you have any questions :)
Flags: needinfo?(yulan.zhu) → needinfo?(whsu)
QA Whiteboard: [MGSEI-Triage+]

Comment 15

3 years ago
(In reply to Lancy from comment #14)
> Created attachment 8690749 [details]
> Portuguese from Brazil&Slovenian.png
> 
> Hi William,
> This issue is verified as "Pass" on latest v2.5 and master build in English,
> Arabic, Czech, Spanish, Serbian Cyrillic, Romanian, Portuguese from
> Portugal, Dutch, Swedish, Urdu, Japanese, Traditional Chinese, Bengali from
> Bangladesh, Bengali from India, Slovak, Songhay, Albanian, Bosnian and
> Basque languages, "Legacy Home Screen" and "Default Home Screen" are shown
> in "Change Home Screen" view and translated to local language.
> 
> But in Portuguese from Brazil and Slovenian languages, "Change Home Screen"
> shows both the old and new homescreens with the same name on v2.5&master
> build.
> 
> See attachment:Portuguese from Brazil&Slovenian.png

Hi, Lancy,

Thanks for your help.
Can we file a follow-up bug?
Flags: needinfo?(whsu) → needinfo?(yulan.zhu)
Hi William,
Bug 1227433 (Portuguese from Brazil) and bug 1227442 (Slovene) are submitted. :)
Flags: needinfo?(yulan.zhu) → needinfo?(whsu)

Comment 17

3 years ago
(In reply to Lancy from comment #16)
> Hi William,
> Bug 1227433 (Portuguese from Brazil) and bug 1227442 (Slovene) are
> submitted. :)

Thanks for your help!
Flags: needinfo?(whsu)
You need to log in before you can comment on or make changes to this bug.