Closed Bug 1222992 Opened 6 years ago Closed 2 years ago

Append error message "Sending of message failed." with more detailed info such as read/write errors.

Categories

(Thunderbird :: General, enhancement)

42 Branch
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: martin.monperrus, Unassigned)

Details

(Whiteboard: [dupeme?])

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

Send a message


Actual results:

 During "Assembling message...", an error happens and the message 
"Sending of message failed." pops up


Expected results:

The cause is that the temp folder (/tmp) is not writable, the popup should say "temp/cache folder (/tmp) is not writable"
Summary: Wrong error message when temp folder (/tmp) is not writable → Wrong error message "Sending of message failed." when temp folder (/tmp) is not writable
Whiteboard: [dupeme?]

I can confirm the issue for Thunderbird 60.8.0 (64-bit) on Linux.

If /tmp is write-protected on trying to send a new email a window named "Send Message Error" pops up and says "Sending of the message failed." without any hint of the cause of the problem.

Similar happens when trying to save that unsent message to Drafts: a window named "Save Draft Error" pops up and reports "Unable to save your message as a draft. Sending of the message failed.".

While searching the error messages on the web I found comments that indicate that this problem can occur in Windows too.

I'd have two comments:

  • an improved error message would be helpful to diagnose and solve the problem quickly
  • for privacy reasons it might be better to use a temporary directory inside the user's Thunderbird mail directory

Kind regards

Thomas,

Thanks for updating this ticket with the new info. The error message could be clearer.

However I'm not sure I agree with the second statement about the privacy concern. /tmp is volatile and erased on boot or via cron job, or both on modern systems. Tie that in with default permissions set that only the owner of the created directory or file has any access to it, and you have a pretty secure setup.

Status: UNCONFIRMED → NEW
Type: defect → enhancement
Component: Untriaged → General
Ever confirmed: true
Summary: Wrong error message "Sending of message failed." when temp folder (/tmp) is not writable → Append error message "Sending of message failed." with more detailed info such as read/write errors.

I don't think this is worth fixing. If you have a write protected /tmp you just messed up your system. You won't be able to use that system properly with just about any applications.

(Also, we do use a subfolder under tmp - there are no privacy implications at all.)

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID

Magnus, I totally agree with sentences two and three of your comment. As it happened Thunderbird was the first affected application.
The problem, as far as Thunderbird is concerned and which I reported, is that the error message is misleading - this is a bug, plain and simple.
If you regard this as not worth fixing that's fine with me - but then I would argue that it belongs on a list of known bugs that's searchable instead of being declared invalid.
Sorry for having brought in the privacy issue - you're correct that that's not a bug but a design decision. Let me just comment that changing the temp dir to somewhere inside the users existing mail dir in HOME would avoid the issue in the first place. Just my thoughts.

Kind regards,
Thomas.

I just ran into similar issue with "Save Draft Error" and message "Unable to save your message as a draft. Sending of the message failed."

There is absolutely no indication what's happening. I tried debugging it but my basic MOZ_LOG=IMAP:5 from debugging issue with IMAP archiving didn't result in anything and the most verbose I could come up with didn't yield log file:

export MOZ_LOG=IMAP:5,IMAPOffline:5,Mailbox:5,MailDirStore:5,MsgBiff:5,MsgCompose:5,MsgCopyService:5,MsgDB:5,MsgPurge:5,IMAPAutoSync:5,IMAP_CS:5,IMAP_KW:5,IMAPCache:5,Movemail:5,timestamp
export MOZ_LOG_FILE=$HOME/imap.log
/Applications/Frequenters/Thunderbird.app/Contents/MacOS/thunderbird-bin &

From what I can see, /tmp is not used under macOS an there is no other indication. Nothing has changed in the last couple of days and the issue started yesterday. I'm currently using 78.3.2 and constant modal pop-up is driving me nuts when I tried to write a little lengthier response...

And what's more, it's impossible to disable drafts nor get rid of the dialog by simple hitting space (it requires clicking on the button to confirm), which suddenly makes Thunderbird bordering on being utterly annoying to use.

The dialog itself needs improvement (better information, being able to discard it with space -- though I could see why it was done like that - to avoid accidental discarding it) and it would be nice to fix the issue with draft not being saved (or add option to not use it if someone doesn't care about drafts)

I am encountering the same or a very similar issue. I have a number of e-mail accounts. All save drafts and templates to the relevant folders under Local Folders (or rather should and don't). I have the issue with POP3 accounts. This issue has only arisen in the last month and maybe became apparent after updating. I can not manually save (I get the same message) to either Drafts or Templates folders. The same happens when TB attempts to save a draft for itself.

Sent folder under Local Folders seems to be receiving sent messages without issue. I have tried deleting the msf files and re-starting. The msf files are re-created without an issue but I cannot save to the folders.

If I re-assign the Drafts and/or Templates folder in Account settings to a newly created folder (called "nonsense" for example, under Local Folders, the issue and the messages I get remain the same. This is not a corruption issue.

I have noticed the following, which may be of use. Each time I attempt a save (whether to Drafts or Templates folders) an nsmail.eml file of zero length is created in my User Windows Temp/Tmp directory. The file name is incremented by 1 each time, so on the second occasion there will also be an nsmail-1.eml file of zero length. I'm unsure why the Windows Temp directory would be used to attempt to save potential e-mails? Note that the nsmail.eml files are created in the Windows User Temp directory (NOT a Mozilla or TB subdirectory of that directory). Again, there isn't an issue writing to the directory as I get a zero length file in there. The problem seems to be a TB issue to me.

I have it set up that all drafts and templates are saved to the folders immediately under Local Folders, and this has been fine for years. It has just stopped working for no apparent reason. Personally, this is a bug, whatever way you look at it as the error message is not appropriate to the situation - I am not attempting to send the message. I don't think this can be described as a feature.

Like wojtec, I find this frustrating and potentially really problematic as I use templates a lot. PS. I compress files almost religiously many times a day.

I had the same annoying "Unable to save your message as a draft. Sending of the message failed." problem. It turned out that during the migration away from enigma my private pgp-key went lost. Importing the key resolved the problem. Apparently, if old messages in the draft folder cannot be decrypted due to a missing key, this triggers this message.

P.S.: I never would have expected this to be the reason -- a colleague of mine pointed me to this possibility. The same can happen if there are encrypted messages using expired keys from the senders.

P.P.S.: It seems to me that the error messages of TB leave some room for improvements.

Thank you @ypfmde

I had slightly different issue - I was using smartcard and it obviously failed so I disabled encryption for that account... yet it seems that thunderbird was still trying to use it (the half-key was still available in the keyring). I removed it from keyring and voila, the error changed to "OpenPGP Alert: Error while saving draft - The configured key ID '0x5E1…' cannot be found on your keyring.". The thing is - from what I can see I don't have anywhere configured PGP for this account anymore. In account settings I see "Thunderbird doesn't have personal OpenPGP key for <email>" and in message in Security "Do not encrypt" is selected.
How can I permanently disable it for this account?

Maybe it's for another identity? Please check all the identities.

I have only single Identity for that account. I have checked it and it states the same "Doesn't have a personal OpenPGP key for <my email>".

Interestingly enough, for other account for which I do have OpenPGP I have Thunderbird with: "found 1 personal OpenPGP key associates with <my email>" and below have option "none" (with description "do not use openpgp for this identity") and "<my key hash>.

It looks like it's not possible to disable OpenPGP?

Same thing here: Save Draft Error. Unable to save your message as a draft. Sending of the message failed.

This happens every time I am composing an email.

TB on Mac 78.5.1.

I seem to remember some message about OpenPGP during a recent upgrade but ignored it since I don't use encryption.

Same error message "Sending of message failed", but different cause.
TB 78.7.0, WIN 10

TB creates temporary files in user's TMP folder with a naming pattern like nsmail-????.eml
And ???? is limited to 9999.
After that - user cannot send messages or save drafts.

You need to log in before you can comment on or make changes to this bug.