firefox/releases/latest-* stale since migration to S3 storage

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: wgianopoulos, Assigned: nthomas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Comment 1

3 years ago
The latest-beta link on the ftp site does not seem to point to the latest beta.  it points to version 42 betas even though version 43 beta1 has been released.
Summary: http://ftp.mozilla.org/pub/firefox/releases/latest-beta/ → http://ftp.mozilla.org/pub/firefox/releases/latest-beta/ pnts to version 42 betas even though 43 beta 1 has been released
(Reporter)

Updated

3 years ago
Summary: http://ftp.mozilla.org/pub/firefox/releases/latest-beta/ pnts to version 42 betas even though 43 beta 1 has been released → http://ftp.mozilla.org/pub/firefox/releases/latest-beta/ points to version 42 betas even though 43 beta 1 has been released
This is related to the FTP-to-S3 migration where there are no <s>spoons</s> symlinks. :)

IIRC there is a bug to make sure that we either stop using "latest" or fix this.
(Assignee)

Comment 3

3 years ago
Lets use this bug for that. I am planning to empty these directories and add a README file which describes how to use download.mozilla.org links instead.
Blocks: 1165405
Component: Releases → Release Automation
QA Contact: rail → bhearsum
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1224017
(Assignee)

Comment 5

3 years ago
I've empted out firefox/releases/latest-beta/ and added http://archive.mozilla.org/pub/firefox/releases/latest-beta/README.txt

Some empty directories are still showing up, hopefully that's just some caching and they'll disappear soon.

Other directories and a blog post to follow.
Assignee: nobody → nthomas
(Reporter)

Comment 6

3 years ago
I used the README file information and shortened my script to download the latest beta considerably in doing so.  It works great!
(Assignee)

Updated

3 years ago
Depends on: 1224963
(Assignee)

Comment 7

3 years ago
I've done Firefox latest, latest-beta, and latest-esr, as well as Thunderbird latest-beta and latest.

Blogged at https://ftangftang.wordpress.com/2015/11/17/the-latest-on-firefoxreleaseslatest/.
(Assignee)

Comment 8

3 years ago
Created attachment 8688157 [details] [diff] [review]
[buildbot-configs] Update thunderbird-beta-latest alias

We already have a thunderbird-latest, and 3 for firefox, so this completes the set.
Attachment #8688157 - Flags: review?(rail)

Comment 9

3 years ago
What about mobile/firefox for android?
(Assignee)

Comment 10

3 years ago
I looked at that. The main multi-locale builds are distributed by Google Play, so we don't have a download.m.o link for them. We'd need a 'multi' locale in bouncer to support that, not sure how hard that would be to get into product-details and then deployed. Traditionally this has been a slow process.

The single locale builds do kinda get set up, except the work on bug 1019724 stalled and since then we've split the arm build in api-11+ and api-9/10.

So multiple issues to fix for a very much lower traffic situation, which makes it low priority work compared to other things on my plate right now.
Attachment #8688157 - Flags: review?(rail) → review+
(Assignee)

Comment 11

3 years ago
Comment on attachment 8688157 [details] [diff] [review]
[buildbot-configs] Update thunderbird-beta-latest alias

https://hg.mozilla.org/build/buildbot-configs/rev/c52cedd661ab
Attachment #8688157 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Summary: http://ftp.mozilla.org/pub/firefox/releases/latest-beta/ points to version 42 betas even though 43 beta 1 has been released → firefox/releases/latest-* stale since migration to S3 storage
(Assignee)

Updated

3 years ago
Blocks: 1175086
(Assignee)

Comment 12

3 years ago
Fixed as filed (ie firefox). Mobile is problematic, we need bug 1226476 to modify www.mozilla.org to stop using mobile/releases/latest/.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.