Error in install-plugin: getMsg not defined

VERIFIED FIXED

Status

defect
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: tonymec, Assigned: Gijs)

Tracking

SeaMonkey Tracking Flags

(seamonkey2.42 fixed)

Details

(Whiteboard: [cz-0.9.93])

Attachments

(4 attachments)

UA:"Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0 SeaMonkey/2.42a1" ID:20151104003002 c-c:071eec01aca961c0d603b94c41a89a17645f4af6 m-c:f742b9412ed5aace90ad863b276faae0641090a8 en-US

ChatZilla 0.9.92 but reported as <unknown> in client tab

	[INFO]	Installing from '/root/.download/mozilla/chazilla/cz_sasl.js' to '/root/.mozilla/seamonkey/eiox68r9.default/chatzilla/scripts'…
	[ERROR]	Internal error dispatching command “install-plugin”.
	[ERROR]	ReferenceError: getMSg is not defined @ <chrome://chatzilla/content/static.js> 3447

Shall I create <profile>/chatzilla/scripts/cz_sasl/ and drop the script into it as init.js ?
(In reply to Tony Mechelynck [:tonymec] from comment #0)
> Shall I create <profile>/chatzilla/scripts/cz_sasl/ and drop the script into
> it as init.js ?

After the following
1. Drop the plugin as said above
2. /quit and restart ChatZilla (which loads and enables the plugin)
3. Set the plugin prefs as desired (sasl.username, sasl.password, sasl.server)
4. reconnect the server in question (freenode)

SASL authentication works as desired.

This is a workaround, not a fix, since the /install-plugin command is still broken AFAIK.
Whiteboard: [workaround see comment #1]
Attachment #8685317 - Flags: review?(bugzilla-mozilla-20000923)
So there's an error with the plugin but our logging code being broken means we can't see what it is. The patch I attached should fix this. I'll add an XPI which has this addressed so you can see what it is...
(In reply to :Gijs Kruitbosch from comment #3)
> So there's an error with the plugin but our logging code being broken means
> we can't see what it is. The patch I attached should fix this. I'll add an
> XPI which has this addressed so you can see what it is...

As noted in comment #1, the plugin works OK once it has been, so to say, "installed by hand", circumventing the faulty code.

Thanks, Gijs, for looking into this. As long as SeaMonkey isn't building on linux-x86_64 I won't get the new ChatZilla as /usr/local/seamonkey/distribution/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi, and it seems that in my hard disk crash I lost the bookmark to the cZ nightly builds site, so a *lot* of thanks for the foresight of providing a fixed chatzilla.xpi :-) :-) :-)
P.S. Found the URL back, and bookmarked http://james-ross.co.uk/mozilla/chatzilla/nightly/builds/

Gijs: there used to be a plugin which told me when someone ran a CTCP query on me (including /version or /time). Do you remember where I can find it so I can try installing it as a test of the fixed XPI? I looked at all the "scripts" sites linked from Silver's page but none of those I saw rang a bell.
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Tony Mechelynck [:tonymec] from comment #6)
> P.S. Found the URL back, and bookmarked
> http://james-ross.co.uk/mozilla/chatzilla/nightly/builds/
> 
> Gijs: there used to be a plugin which told me when someone ran a CTCP query
> on me (including /version or /time). Do you remember where I can find it so
> I can try installing it as a test of the fixed XPI? I looked at all the
> "scripts" sites linked from Silver's page but none of those I saw rang a
> bell.

Alas ISTR it was one of wormxulla's plugins, but http://corpsmoderne.net/~eve97/gothdns/chatzillapage.htm#Scripts_other now gives Error 404.
Comment on attachment 8685317 [details] [diff] [review]
fix typo in getMsg calls,

Review of attachment 8685317 [details] [diff] [review]:
-----------------------------------------------------------------

Whoops, r+
Attachment #8685317 - Flags: review?(bugzilla-mozilla-20000923) → review+
remote:   https://hg.mozilla.org/chatzilla/rev/bfc8dea4cfab

(In reply to Tony Mechelynck [:tonymec] from comment #5)
> (In reply to :Gijs Kruitbosch from comment #3)
> > So there's an error with the plugin but our logging code being broken means
> > we can't see what it is. The patch I attached should fix this. I'll add an
> > XPI which has this addressed so you can see what it is...
> 
> As noted in comment #1, the plugin works OK once it has been, so to say,
> "installed by hand", circumventing the faulty code.

Can you remove it and try to call install-plugin again? The error you saw was in ChatZilla's code, but it was in code that handled errors from the plugin, so now we still don't know what the error was that loading the plugin produced. It would be good to know that, in part because I expect fallout on Nightly from e.g. changes to let/const in javascript.
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(antoine.mechelynck)
In reply to comment #9:

/uninstall-plugin cz_sasl
[ERROR]  The command “uninstall-plugin” is not known to ChatZilla.
/disable-plugin cz_sasl
 [INFO]  disabling cz_sasl
 [INFO]  Plugin "cz_sasl" is now disabled.

# rm -Rv ~/.mozilla/seamonkey/eiox68r9.default/chatzilla/scripts/cz_sasl
removed ‘/root/.mozilla/seamonkey/eiox68r9.default/chatzilla/scripts/cz_sasl/init.js’
removed directory: ‘/root/.mozilla/seamonkey/eiox68r9.default/chatzilla/scripts/cz_sasl’

/install-plugin file:///root/.download/mozilla/chatzilla/install-plugin.js
[ERROR]  An error occurred installing the source: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIFileInputStream.init]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://chatzilla/content/lib/js/file-utils.js :: LocalFile :: line 379"  data: no]

# mkdir -pv ~/.mozilla/seamonkey/eiox68r9.default/chatzilla/scripts/cz_sasl
mkdir: created directory ‘/root/.mozilla/seamonkey/eiox68r9.default/chatzilla/scripts/cz_sasl’
# cp -v ~/.download/mozilla/chatzilla/cz_sasl.js ~/.mozilla/seamonkey/eiox68r9.default/chatzilla/scripts/cz_sasl
‘/root/.download/mozilla/chatzilla/cz_sasl.js’ -> ‘/root/.mozilla/seamonkey/eiox68r9.default/chatzilla/scripts/cz_sasl/cz_sasl.js’

/install-plugin file:///root/.download/mozilla/chatzilla/init-awayall.js
   [INFO]	Installing from '/root/.download/mozilla/chatzilla/init-awayall.js' to '/root/.mozilla/seamonkey/eiox68r9.default/chatzilla/scripts'…
[WARNING]	Changed plugin name for install from 'init-awayall' to 'awayall' to match source code.
   [INFO]	Plugin “awayall” is now enabled.
   [INFO]	Done. ChatZilla plugin 'awayall' installed!
Flags: needinfo?(antoine.mechelynck)
Oops! Typo in install-plugin operand!

/install-plugin file:///root/.download/mozilla/chatzilla/cz_sasl.js
	[INFO]	Installing from '/root/.download/mozilla/chatzilla/cz_sasl.js' to '/root/.mozilla/seamonkey/eiox68r9.default/chatzilla/scripts'…
	[INFO]	cz_sasl loaded from url file:///root/.mozilla/seamonkey/eiox68r9.default/chatzilla/scripts/cz_sasl/init.js
	[INFO]	Done. ChatZilla plugin 'cz_sasl' installed!
P.S. Unlike awayall, cz_sasl installs in disabled state. After enabling it, checking its prefs, and reconnecting freenode, SASL authentication works as expected.
(In reply to Tony Mechelynck [:tonymec] from comment #12)
> P.S. Unlike awayall, cz_sasl installs in disabled state. After enabling it,
> checking its prefs, and reconnecting freenode, SASL authentication works as
> expected.

Almost certainly because of the explicit /disable-plugin earlier, as the plugin preferences persist no matter whether the plugin exists. Good to see it works though.
(In reply to James Ross from comment #13)
> (In reply to Tony Mechelynck [:tonymec] from comment #12)
> > P.S. Unlike awayall, cz_sasl installs in disabled state. After enabling it,
> > checking its prefs, and reconnecting freenode, SASL authentication works as
> > expected.
> 
> Almost certainly because of the explicit /disable-plugin earlier, as the
> plugin preferences persist no matter whether the plugin exists. Good to see
> it works though.

:-) In case anyone asks you about SASL, I got it from a link labeled as "ChatZilla, using cz_sasl.js" on page https://freenode.net/sasl/ linked from the freenode FAQ.
The fact that the patch has been pushed into the repo at about the time of comment #8 was never reported in this bug.

http://hg.mozilla.org/chatzilla/rev/bfc8dea4cfab

I've been testing the fixed version (attachment #8685318 [details]) since the time of comment #5, with success, so I feel I can declare it VERIFIED FIXED.
Assignee: rginda → gijskruitbosch+bugs
Status: NEW → RESOLVED
Closed: 4 years ago
OS: Linux → All
Hardware: x86_64 → All
Resolution: --- → FIXED
Whiteboard: [workaround see comment #1] → [workaround see comment #1] [fixed in the next release after 0.9.92]
Status: RESOLVED → VERIFIED
Oops! Trying to click on the link to {59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi in the page for file:///usr/local/seamonkey/distribution/extensions/ in SeaMonkey 2.43a1 dated 201512170033002 doesn't work: the dowload starts, then the door hanger says "The add-on downloaded from could not be installed because it appears to be corrupt".

Let's try the roundabout way: First, copy that .xpi by "Save Link Target As" to ~/.download/mozilla/seamonkey/chatzilla+bug1223210.xpi. Next, let's try "Install Add-on from File..." at that new location by means of the rolldown widget in the add-ons manager.

Same problem: "The add-on downloaded from unknown host could not be installed because it appears to be corrupt".

Notes:
- I am on SeaMonkey 2.43a1, details at bottom of this comment
- xpinstall.signatures.required is false (the SeaMonkey default)
- extensions.checkCompatibility.nightly is also false.
- I'm going to attach the "corrupt" XPI (but as if it were a .zip) because I don't know if the problem is in the ChatZilla code, in the SeaMonkey RelEng code, or in the Toolkit add-ons manager code.

UA:"Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0 SeaMonkey/2.43a1" ID:20151217003002 c-c:c7fb0822b04746fcb1321ab430a471160459e20c m-c:0babaa3edcf908c393b68a3dc2d1c2a2450c31ed en-US
Posted file The «corrupt» XPI
I know Gijs is on holiday. Let's hope someone can have a look at this. In the meantime, use attachment #8685318 [details].
(In reply to Tony Mechelynck [:tonymec] from comment #17)
> Created attachment 8700279 [details]
> The «corrupt» XPI
> 
> I know Gijs is on holiday. Let's hope someone can have a look at this. In
> the meantime, use attachment #8685318 [details].

There is an install.rdf in ./xpi/resources at that changeset (current "default" branch head for hg.mozilla.org/chatzilla, but not at top level in /usr/local/seamonkey/distribution/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi

This points to a SeaMonkey Build Config problem. I'll file a new bug and report its bug ID here.
The SeaMonkey Build Config bug which I just filed (as I said in comment #18) is bug 1233969. It affects also the packaged-in DOMi but not the packaged-in debugQA.
Whiteboard: [workaround see comment #1] [fixed in the next release after 0.9.92] → [cz-0.9.93]
You need to log in before you can comment on or make changes to this bug.