crash in memset | arena_dalloc_large | free_impl | mozilla::layers::Transaction::~Transaction

RESOLVED INCOMPLETE

Status

()

Core
Graphics: Layers
--
critical
RESOLVED INCOMPLETE
3 years ago
a year ago

People

(Reporter: alex_mayorga, Unassigned)

Tracking

(Blocks: 1 bug, {crash})

45 Branch
x86
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
¡Hola!

nhirata suggested I filed this bug on IRC #qa

¡Gracias!
Alex

This bug was filed from the Socorro interface and is 
report bp-7464b0ee-5494-4844-881c-2012d2151110.
=============================================================

Crashing Thread
Frame 	Module 	Signature 	Source
0 	msvcr120.dll 	memset 	f:\dd\vctools\crt\crtw32\string\amd64\memset.asm:147
1 	mozglue.dll 	arena_dalloc_large 	memory/mozjemalloc/jemalloc.c
2 	mozglue.dll 	free_impl 	memory/build/replace_malloc.c
3 	xul.dll 	mozilla::layers::Transaction::~Transaction() 	
4 	xul.dll 	mozilla::layers::ShadowLayerForwarder::~ShadowLayerForwarder() 	gfx/layers/ipc/ShadowLayers.cpp
5 	xul.dll 	mozilla::layers::ShadowLayerForwarder::`scalar deleting destructor'(unsigned int) 	
6 	xul.dll 	mozilla::AtomicRefCountedWithFinalize<mozilla::layers::ISurfaceAllocator>::Release() 	gfx/layers/AtomicRefCountedWithFinalize.h
7 	xul.dll 	mozilla::layers::ClientLayerManager::~ClientLayerManager() 	gfx/layers/client/ClientLayerManager.cpp
8 	xul.dll 	mozilla::layers::ClientLayerManager::`scalar deleting destructor'(unsigned int) 	
9 	xul.dll 	mozilla::layers::LayerManager::Release() 	gfx/layers/Layers.h
10 	xul.dll 	mozilla::widget::PuppetWidget::Destroy() 	widget/PuppetWidget.cpp
11 	xul.dll 	mozilla::dom::TabChild::DestroyWindow() 	dom/ipc/TabChild.cpp
12 	xul.dll 	mozilla::dom::TabChild::RecvDestroy() 	dom/ipc/TabChild.cpp
13 	xul.dll 	mozilla::dom::PBrowserChild::OnMessageReceived(IPC::Message const&) 	obj-firefox/ipc/ipdl/PBrowserChild.cpp
14 	xul.dll 	mozilla::dom::PContentChild::OnMessageReceived(IPC::Message const&) 	obj-firefox/ipc/ipdl/PContentChild.cpp
15 	xul.dll 	mozilla::ipc::MessageChannel::DispatchAsyncMessage(IPC::Message const&) 	ipc/glue/MessageChannel.cpp
16 	xul.dll 	mozilla::ipc::MessageChannel::DispatchMessageW(IPC::Message const&) 	ipc/glue/MessageChannel.cpp
17 	xul.dll 	mozilla::ipc::MessageChannel::OnMaybeDequeueOne() 	ipc/glue/MessageChannel.cpp
18 	xul.dll 	RunnableMethod<mozilla::ipc::MessageChannel, bool ( mozilla::ipc::MessageChannel::*)(void), Tuple0>::Run() 	ipc/chromium/src/base/task.h
19 	xul.dll 	MessageLoop::DoWork() 	ipc/chromium/src/base/message_loop.cc
20 	xul.dll 	mozilla::ipc::DoWorkRunnable::Run() 	ipc/glue/MessagePump.cpp
21 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
22 	xul.dll 	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
23 	xul.dll 	mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
24 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
25 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
26 	xul.dll 	nsBaseAppShell::Run() 	widget/nsBaseAppShell.cpp
27 	xul.dll 	nsAppShell::Run() 	widget/windows/nsAppShell.cpp
28 	xul.dll 	XRE_RunAppShell 	toolkit/xre/nsEmbedFunctions.cpp
29 	xul.dll 	mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
30 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
31 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
32 	xul.dll 	XRE_InitChildProcess 	toolkit/xre/nsEmbedFunctions.cpp
33 	plugin-container.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp
34 	plugin-container.exe 	__tmainCRTStartup 	f:/dd/vctools/crt/crtw32/startup/crt0.c:255
35 	kernel32.dll 	BaseThreadInitThunk 	
36 	ntdll.dll 	RtlUserThreadStart
Thanks Alex, it looks like yours is the only report in crash-stats. Do you have reliable steps to reproduce?
(Reporter)

Comment 2

3 years ago
¡Hola Anthony!

Sadly I do not have steps.

Filed per Naoki's request on IRC.

¡Hola Naoki!

Could you please elaborate as to what is of interest in this crash?

¡Gracias!
Alex
Flags: needinfo?(nhirata.bugzilla)
Like I said in comment 1, your report is literally the *only* report we have. If it's not repeatable by you or anyone else then there's nothing we can do about it. I don't have context for the conversation you had on IRC but I think this should just be closed. Please reopen if there's something more concrete to be investigated.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
My guess based on what is going on is the top page was twitter, a link off of this was used (which I don't know what it was... ) and then the tab was closed.

Probably some thing in the website format (some funky layout or some thing along those lines) wasn't well received when trying to close the tab which caused a crash.

Did you do anything like this?  If so, please try to redo your steps to see if you can make this reproducible.
Flags: needinfo?(nhirata.bugzilla) → needinfo?(alex_mayorga)
(Reporter)

Updated

3 years ago
Flags: needinfo?(alex_mayorga)
Updating crash signature to reflect changes to signature generation made in bug 1269817 (although reports older than a week will not be reprocessed), and adding dependency to ShutDownKill metabug.

(These probably shouldn't all be separate bugs, but I'm not going to fix that up in a mass-change.)
Blocks: 1219672
Crash Signature: [@ memset | arena_dalloc_large | free_impl | mozilla::layers::Transaction::~Transaction] → [@ IPCError-browser | ShutDownKill ]
Crash Signature: [@ IPCError-browser | ShutDownKill ]
status-firefox45: affected → ---
Resolution: WONTFIX → INCOMPLETE
I'm marking this bug as INCOMPLETE, per no STR from OP.

Reproducible bugs are tracked in blocked bug #1219672.
You need to log in before you can comment on or make changes to this bug.