Sound indicator increases pinned tab content's width by 1px

VERIFIED FIXED in Firefox 46

Status

()

defect
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: arni2033, Assigned: Ehsan)

Tracking

({regression})

Trunk
Firefox 48
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox45 affected, firefox46 verified, firefox47 verified, firefox48 verified)

Details

Attachments

(1 attachment)

STR:   (Win7_64, Nightly 45, 32bit, ID 20151108030417, new profile)
1. Open new window, open 2 tabs in that window, pin active tab
2. Press Ctrl+M so that tab displayed "Muted" sound indicator

Result:
 Right ugly-curved tab border AND all other tabs AND new tab button [+] teleports to the right by 1px

Expectations:
 They should stay still = pinned tab content's width shouldn't increase.

Note:
 Please request a screencast if you can't reproduce this yourself.
 I experience this very often, because I have https://vk.com/ loaded in the 1st pinned tab.
 VK.com is russian social network that uses sound notifications about new messages, so all tabs twitch
Keywords: regression
I think that .tab-icon-overlay should have "margin-inline-end: -1px;" - works for me.
>   .tab-icon-overlay{
>     margin-inline-end: -1px;
>   }
Has STR: --- → yes
ehsan, can you take a look or find an owner please?
Assignee: nobody → ehsan
Comment on attachment 8728136 [details] [diff] [review]
Avoid expanding the width of a pinned tab when displaying the overlay icon

Review of attachment 8728136 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me, would be nice to get this uplifted to aurora as it's a simple css change.
Attachment #8728136 - Flags: review?(jaws) → review+
Comment on attachment 8728136 [details] [diff] [review]
Avoid expanding the width of a pinned tab when displaying the overlay icon

Approval Request Comment
[Feature/regressing bug #]: Bug 1207166
[User impact if declined]: comment 0
[Describe test coverage new/current, TreeHerder]: locally
[Risks and why]: simple css change, risk free
[String/UUID change made/needed]: none
Attachment #8728136 - Flags: approval-mozilla-beta?
Attachment #8728136 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/ecfe8eaa0ea7
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
Comment on attachment 8728136 [details] [diff] [review]
Avoid expanding the width of a pinned tab when displaying the overlay icon

Simple enough, taking it.
Attachment #8728136 - Flags: approval-mozilla-beta?
Attachment #8728136 - Flags: approval-mozilla-beta+
Attachment #8728136 - Flags: approval-mozilla-aurora?
Attachment #8728136 - Flags: approval-mozilla-aurora+
Fixed on:   Win7_64, Nightly 48, 32bit, ID 20160310030242
Status: RESOLVED → VERIFIED
Flags: qe-verify+
I've managed to reproduce the bug on the affected builds, using Windows 10 x64.

This is verified fixed on:
- 46.0b2-build3 (20160316065941),
- 47.0a2 (2016-03-15),
- 48.0a1 (2016-03-15),
using Windows 10 x64, Windows 7 x64, Ubuntu 12.04 (x86) and Mac OS X 10.7.
Duplicate of this bug: 1247449
You need to log in before you can comment on or make changes to this bug.