Closed Bug 1224101 Opened 4 years ago Closed 4 years ago

Backout the patches causing bug 1218032 from Aurora

Categories

(Core :: DOM: Core & HTML, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla44
Tracking Status
firefox43 --- unaffected
firefox44 - fixed
firefox45 --- fixed

People

(Reporter: masayuki, Assigned: masayuki)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #1218032 +++

The patches for bug 1218032 are risky to uplift. On the other hand, the regression causes, bug 1213589 and bug 1215798, are not necessary for Aurora since they are preparation to fix bug 1218032 but bug 1218032 is still being worked on m-c.

So, we should back them out from Aurora.
> the regression causes, bug 1213589 and bug 1215798

correct regression bug# is bug 1215798 and bug 1215798's patch depends on it.
Blocks: 1218032
No longer blocks: 1213589, 1215798
No longer depends on: 1218032
Already reviewed in bug 1218032.

Approval Request Comment
[Feature/regressing bug #]: bug 1215798 (and bug 1215816 depends on it)
[User impact if declined]: When modifying DOM tree nodes in rich text editor, user meets the crash (e.g., when removing bold text)
[Describe test coverage new/current, TreeHerder]: tested manually and I posted the patches to tryserver: https://treeherder.mozilla.org/#/jobs?repo=try&revision=918eec38037c
[Risks and why]: Nothing. The patch isn't necessary for Aurora because it's preparation of bug 1213589 but it's sill not been fixed even on m-c yet.
[String/UUID change made/needed]: nothing.
Attachment #8686446 - Flags: approval-mozilla-aurora?
See above. And also this was reviewed in bug 1218032 comment 72.
Attachment #8686448 - Flags: approval-mozilla-aurora?
Comment on attachment 8686446 [details] [diff] [review]
part.1 Backout bug 1215816 from Aurora (r=smaug)

Backing out a patch to fix a crash, let's uplift to Aurora44.
Attachment #8686446 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
There is no need to track this bug, it will show up on the right queries used by Sheriffs for Aurora uplifts.
Comment on attachment 8686448 [details] [diff] [review]
part.2 Backout bug 1215798 from Aurora (r=smaug)

Backout to fix a crash, approved.
Attachment #8686448 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Tomcat, Wes: This is a patch was approved a few days back and needs to land soon on Aurora as it addresses a top crash. Please let me know if I can help in anyway.
Flags: needinfo?(wkocher)
Flags: needinfo?(cbook)
-> FIXED per comment 8
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.