Closed Bug 1224233 Opened 6 years ago Closed 6 years ago

crash in mozilla::IMEContentObserver::IMENotificationSender::Run when using on-screen (touch) keyboard on Windows 8+

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

All
Windows 8
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Tracking Status
firefox42 --- unaffected
firefox43 --- unaffected
firefox44 --- unaffected
firefox45 --- affected
firefox-esr38 --- unaffected

People

(Reporter: Gijs, Assigned: Gijs)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-7f85fadc-0419-44b0-9ed6-f79682151112.
=============================================================
STR:

1. open firefox on windows 8+
2. open about:config
3. filter for "ui.osk"
4. turn off keyboard detection
5. focus location bar / search bar in turn

ER:
you get an on-screen keyboard

AR:
you get an on-screen keyboard and Firefox crashes


Happens both with and without e10s

Olli had a suggestion about how to fix, testing now.

(this is an access violation non-nullptr crash, so hiding for now)
OS: Windows NT → Windows 8
Hardware: Unspecified → All
Summary: crash in mozilla::IMEContentObserver::IMENotificationSender::Run → crash in mozilla::IMEContentObserver::IMENotificationSender::Run when using on-screen (touch) keyboard on Windows 8+
This was Olli's suggestion and it fixes the crash for me (and, having seen the suggestion, it makes sense to me why this would fix the crash, etc. etc.)
Attachment #8686635 - Flags: review?(bugs)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Attachment #8686635 - Flags: review?(bugs) → review+
This was a regression from bug 1218032 which only landed on central. That bug affects aurora, but aurora will be fixed by backing out other patches, so this only affects m-c and so per:

https://wiki.mozilla.org/Security/Bug_Approval_Process

I think I can just land this irrespective of what severity this would end up as.
Duplicate of this bug: 1224562
This was merged:

https://hg.mozilla.org/mozilla-central/rev/f3ab1f50450a

but missed today's nightly. Will be fixed in tomorrow's.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Group: core-security → core-security-release
Group: core-security-release
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.