If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Async scrollbars break list box & combo box scrolling

RESOLVED FIXED in Firefox 45

Status

()

Core
Panning and Zooming
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: BenWa, Assigned: BenWa)

Tracking

unspecified
mozilla45
Points:
---

Firefox Tracking Flags

(firefox45 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

2 years ago
Async scrollbars breaks list boxes and combo boxes scroll-bars (mouse wheel still works). I can reproduce this in bugzilla.
(Assignee)

Comment 1

2 years ago
Created attachment 8692209 [details] [diff] [review]
patch

Before I was trying GetDisplayPort with the PresShell. I recall trying with scrollabeContent but perhaps I didn't or messed something up. It is working indeed and the DisplayPort atom is only set from a test AFAIK. So everything is working as expected.

I also sneaked in a trivial check. It's triggered from the startup crash dialog which presumably is running under safe mode.

I don't plan on running this through try since it's behind a preference and unlikely to cause build failures.
Assignee: nobody → bgirard
Status: NEW → ASSIGNED
Attachment #8692209 - Flags: review?(bugmail.mozilla)
Comment on attachment 8692209 [details] [diff] [review]
patch

Review of attachment 8692209 [details] [diff] [review]:
-----------------------------------------------------------------

There's a bunch of GL stuff in this patch that doesn't belong. r+ for the nsSliderFrame.cpp change, with a comment. Not sure if you intended to include the APZCTreeManager change or not, that seems unrelated. Let me know if that change was intentional, and if so, why.
Attachment #8692209 - Flags: review?(bugmail.mozilla) → review+
(Assignee)

Comment 3

2 years ago
Ahh yes, that's a mistake. Thanks for overlooking it. I'll split it up before landing.
(Assignee)

Comment 4

2 years ago
Created attachment 8693026 [details] [diff] [review]
patch
Attachment #8692209 - Attachment is obsolete: true
Attachment #8693026 - Flags: review+
(Assignee)

Comment 5

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/1211fe850c050db6c21df7138a399039f67b77d7
Bug 1225178 - Don't start APZ drag if we don't have a displayport to handle it. r=kats

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1211fe850c05
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox45: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
You need to log in before you can comment on or make changes to this bug.