Closed Bug 1211610 (async-scrollbar-drag) Opened 4 years ago Closed 3 years ago

[Meta] Enable async scrolling via scrollbar dragging

Categories

(Core :: Panning and Zooming, defect)

42 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: BenWa, Assigned: botond)

References

(Depends on 2 open bugs)

Details

(Keywords: feature, meta, Whiteboard: [gfx-noted])

Attachments

(1 file)

We're splitting bug 1199885 into several parts. This will track all the work required to get it turn on by default.
Depends on: 1211612
Depends on: 1219929
Depends on: 1220853
Depends on: 1221593
Depends on: 1225178
Depends on: 1249710
Depends on: 1249749
Depends on: 1249750
Depends on: 1250649
Depends on: 1251617
Alias: async-scrollbar-drag
Depends on: 1324117
Depends on: 1333965
Do you guys think it's worth filing a new parent bug to this one about webcompat.com issue #4664? Basically, when dragging the scrollbar quickly enough, there are blank content-areas for the given URL, but it doesn't result in breakage (it seems to basically just be checkerboarding). It only seems to happen when dragging the scrollbar, and it doesn't happen when apz.drag.enabled is off. I'm just not sure if that would mean it's related to this bug specifically, or APZ checkboarding in general.

https://github.com/webcompat/web-bugs/issues/4664
I think the checkerboarding-while-dragging-scrollbar is mostly covered by bug 1251617. Even though that cites a specific URL it's a more general issue. Feel free to link that bug up to the webcompat issue.
(In reply to Thomas Wisniewski from comment #2)
> https://github.com/webcompat/web-bugs/issues/4664

This is general APZ checkerboarding. If you scroll sufficient fast with other APZ input methods (mouse wheel, touchpad, touchscreen), you see it as well. I don't think there's a need to file a bug specifically for that site.
No longer depends on: 1333965
Depends on: 1344814
No longer depends on: 1344814
Depends on: 1348321
Depends on: 1349236
Depends on: 1349750
Depends on: 1350902
Depends on: 1353284
Given the number of issues reported in the last few days for this feature I'm inclined to hold off on letting it ride the trains in 55, unless a significant number of the issues are fixed. (I'm assuming that won't happen because we don't have a lot of time to work on it). Bug 1355374 and bug 1355376 in particular seem rather bad, so if we're prioritizing fixes I would like to see those fixed first. The rest of the recent bugs seem to be largely related to scrollbar painting and motion off by a pixel which I suspect all have the same root cause.
Depends on: 1357904
Depends on: 1359868
Also for the record - given that most of the issues have been fixed since I wrote comment 5, I'm fine with letting this ride the trains in 55.
Assignee: nobody → botond
Comment on attachment 8872381 [details]
Bug 1211610 - Let async scrollbar dragging ride the trains.

https://reviewboard.mozilla.org/r/143892/#review147614
Attachment #8872381 - Flags: review?(bugmail) → review+
Pushed by bballo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5d35bf170804
Let async scrollbar dragging ride the trains. r=kats
https://hg.mozilla.org/mozilla-central/rev/5d35bf170804
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Depends on: 1371299
Depends on: 1378455
Depends on: 1363219
Depends on: 1382629
Depends on: 1413093
You need to log in before you can comment on or make changes to this bug.