[TV][2.5] Showing a list of apps as a row

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jyeh, Assigned: jyeh, Mentored)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.5+)

Details

(Whiteboard: [ft:conndevices])

Attachments

(1 attachment, 2 obsolete attachments)

Comment hidden (empty)
(Assignee)

Updated

3 years ago
Blocks: 1204762
(Assignee)

Updated

3 years ago
Assignee: nobody → jyeh
Summary: Showing a list of apps with seven apps in a row → [TV][2.5] Showing a list of apps with seven apps in a row
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

3 years ago
Created attachment 8688316 [details] [diff] [review]
jostw:josyeh/Marketplace/master/Bug1225354 > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Summary: [TV][2.5] Showing a list of apps with seven apps in a row → [TV][2.5] Showing a list of apps as a row
Comment hidden (obsolete)
(Assignee)

Comment 3

3 years ago
Created attachment 8688350 [details] [diff] [review]
jostw:josyeh/Marketplace/master/Bug1225354 > mozilla-b2g:master
(Assignee)

Comment 4

3 years ago
Comment on attachment 8688350 [details] [diff] [review]
jostw:josyeh/Marketplace/master/Bug1225354 > mozilla-b2g:master

Please ignore the first attachment, I am still not very familiar with Bugzilla...
Attachment #8688350 - Flags: review?(ehung)
Priority: -- → P2
(Assignee)

Comment 5

3 years ago
Created attachment 8689336 [details] [review]
jostw:josyeh/Marketplace/master/Bug1225354 > mozilla-b2g:master
Attachment #8688316 - Attachment is obsolete: true
Attachment #8688350 - Attachment is obsolete: true
Attachment #8688350 - Flags: review?(ehung)
(Assignee)

Updated

3 years ago
Attachment #8689336 - Flags: review?(ehung)
(Assignee)

Comment 6

3 years ago
Comment on attachment 8689336 [details] [review]
jostw:josyeh/Marketplace/master/Bug1225354 > mozilla-b2g:master

I made four commits for this bug.

1. Started from marketplace-template, remove header and footer which is not needed in Marketplace TV.

2. Rename the default view from hello_world to homepage, which is the only view we need. Also remove unused content from hello_world.

3. Install normalize.css from bower and include it in the html.

4. Use defer block to get apps' data from API server and render apps in a row. The API url need update when the backend is ready to use.

Comment 7

3 years ago
Comment on attachment 8689336 [details] [review]
jostw:josyeh/Marketplace/master/Bug1225354 > mozilla-b2g:master

This is the first patch modify from marketplace-template. I quickly went through the patch and it seems just a clean up. I honestly know less about Marketplace frontend code, so it's better to have someone from Marketplace team to review this patch.
David and Lindsay, could you find someone who is able to review? Thanks!
Flags: needinfo?(lsaunders)
Flags: needinfo?(ddurst)
Attachment #8689336 - Flags: review?(ehung) → feedback+
Mentor: dspasovski
Flags: needinfo?(lsaunders)
Flags: needinfo?(ddurst)
(Assignee)

Comment 8

3 years ago
Comment on attachment 8689336 [details] [review]
jostw:josyeh/Marketplace/master/Bug1225354 > mozilla-b2g:master

Hi Davor,

There are four commits for this bug and I have described them at https://bugzilla.mozilla.org/show_bug.cgi?id=1225354#c6.

Can you help me reviewing this? Thanks!
Attachment #8689336 - Flags: review?(dspasovski)

Updated

3 years ago
Duplicate of this bug: 1221773

Updated

3 years ago
blocking-b2g: --- → 2.5+
Priority: P2 → P1

Updated

3 years ago
Whiteboard: [ft:conndevices]

Updated

3 years ago
Duplicate of this bug: 1221776

Comment 11

3 years ago
Comment on attachment 8689336 [details] [review]
jostw:josyeh/Marketplace/master/Bug1225354 > mozilla-b2g:master

robberstamp r+ because spasovski gave his r+ on Github.
Attachment #8689336 - Flags: review?(dspasovski) → review+
(Assignee)

Comment 12

3 years ago
Landed in marketplace-tv-front-end master

https://github.com/mozilla-b2g/marketplace-tv-front-end/commit/76baa1d31ddce1209b19fa496796b22efe9a0b5f
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.