If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

--log-mach-level=debug should be used by default when debug builds are specified

RESOLVED FIXED

Status

Testing
mozregression
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: RyanVM, Assigned: parkouss)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Debug builds are pretty useless without output to the console, so we shouldn't need to use two different command line flags to get debug builds with useful output. In other words, |-B debug| should imply |--log-mach-level=debug| as well.
(Assignee)

Updated

2 years ago
See Also: → bug 1214386
(Assignee)

Comment 1

2 years ago
created a PR for that in bug 1214386 comment 7 since they are closely related.
Assignee: nobody → j.parkouss
Status: NEW → ASSIGNED
(Assignee)

Comment 2

2 years ago
So, fixed in bug 1214386, landed in https://github.com/mozilla/mozregression/commit/0da09ef3373ecb8e9dd7d579781e8f5f59bce3c4.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.