Closed Bug 1225765 Opened 6 years ago Closed 6 years ago

[Gallery]When user crops a picture, the cancel button does not appear as an oval button in the Action Menu.

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.5 verified, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- verified
b2g-master --- verified

People

(Reporter: zhangmingyu, Assigned: kgrandon)

References

Details

(Whiteboard: [2.5-aries-test-run-4])

Attachments

(5 files)

Attached image Flame_v2.6.png
[1.Description]:
[Aries KK v2.5&2.6][Flame KK v2.5&2.6][Gallery]When user goes to gallery and tap a picture to edit and crop,the Cancel button does not appear as an oval button, but a rectangular button similar to other options in the menu.

Found time: 20:07
See attchments: logcat_2007.txt and Flame_v2.6.png.

[2.Testing Steps]: 
Precondition: There is a picture in gallery.
1. Open gallery app.
2. Tap a picture.
3. Tap edit icon.
4. Tap crop icon.
5. Tap the " ..." icon at the right top.

[3.Expected Result]: 
5. The "Cancel" button should appear as an oval button.
 
[4.Actual Result]: 
5. The Cancel button will show as a rectangular button similar to other options in the menu.

[5.Reproduction build]: 
Device: Aries KK v2.5(Affected)
Build ID               20151117132925
Gaia Revision          28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5
Gaia Date              2015-11-17 07:35:12
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/8f193d35090cdceac7a7de513244ef4cd976133f
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151117.123839
Firmware Date          Tue Nov 17 12:38:47 UTC 2015
Bootloader             s1

Device: Flame KK v2.5 512mb(Affected)
Build ID               20151117132020
Gaia Revision          28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5
Gaia Date              2015-11-17 07:35:12
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/8f193d35090cdceac7a7de513244ef4cd976133f
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151117.123256
Firmware Date          Tue Nov 17 12:33:05 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.6 (Affected)
Build ID               20151117222127
Gaia Revision          28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5
Gaia Date              2015-11-17 07:35:12
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8c3a0b58fd51c02c8aca138b0da58445becb037f
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151117.214032
Firmware Date          Tue Nov 17 21:40:40 UTC 2015
Bootloader             s1

Device: Flame KK v2.6  512mb(Affected)
Build ID               20151115150212
Gaia Revision          e8c15ae4e5324a210000ee0a869a962aa542009f
Gaia Date              2015-11-13 00:10:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7cd2d806bd069c0260ff73f023ac85f892b863bf
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151115.184416
Firmware Date          Sun Nov 15 18:44:31 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.2  512mb(Unaffected)
Build ID               20151116032504
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e772f343b736
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151116.073825
Firmware Date          Mon Nov 16 07:38:36 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached file logcat_2007.txt
Duplicate of this bug: 1225764
Assignee: nobody → kevingrandon
Comment on attachment 8689367 [details] [review]
[gaia] KevinGrandon:bug_1225765_gallery_gaia_menu_port > mozilla-b2g:master

Punam or David - could either of you review this patch for me? We need to port the deprecated action_menu to use gaia-menu to fix the cancel button. Thanks!
Attachment #8689367 - Flags: review?(pdahiya)
Attachment #8689367 - Flags: review?(dflanagan)
Comment on attachment 8689367 [details] [review]
[gaia] KevinGrandon:bug_1225765_gallery_gaia_menu_port > mozilla-b2g:master

I'm going to let Punam take this
Attachment #8689367 - Flags: review?(dflanagan)
Comment on attachment 8689367 [details] [review]
[gaia] KevinGrandon:bug_1225765_gallery_gaia_menu_port > mozilla-b2g:master

Hi Kevin,

Patch looks good and has my r+, Thanks for the patch!
Attachment #8689367 - Flags: review?(pdahiya) → review+
[Blocking Requested - why for this release]: I think this should block, as the parent bug does and it's a visual regression.
blocking-b2g: --- → 2.5?
Thank you for the review, in master: https://github.com/mozilla-b2g/gaia/commit/e6d6d8b9bf6044fb079085124080dae88c1f074f
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8689367 [details] [review]
[gaia] KevinGrandon:bug_1225765_gallery_gaia_menu_port > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Platform change requiring UI updates.
[User impact] if declined: Poor UX when using this menu.
[Testing completed]: Manual testing.
[Risk to taking this patch] (and alternatives if risky): Low risk, moving to a shared component.
[String changes made]: None.
Attachment #8689367 - Flags: approval-gaia-v2.5?
This bug has been verified as "pass" on the latest build of Aries KK master and Flame KK master 512mb by the STR in comment 0 .

Actual result: The "Cancel" button is appear as an oval button.

See attachment: Verified_AriesKK_master.png
Reproduce rate: 0/10.

Device: Aries KK master( Pass )
Build ID               20151124014704
Gaia Revision          ea673b5c4cc19c3daca072691a659c68e4c6937f
Gaia Date              2015-11-23 16:41:08
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/19d89caa664dd9309c796929225ee409df5d1ee4
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151124.005529
Firmware Date          Tue Nov 24 00:55:36 UTC 2015
Bootloader             s1

Device: Flame KK master 512mb( Pass )
Build ID               20151123030230
Gaia Revision          bae13c9ac6a91beecd7c94384e2aef25ed1a3214
Gaia Date              2015-11-23 04:08:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8b1fc0961a076e35646d0472a81feefc0074558c
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151123.064256
Firmware Date          Mon Nov 23 06:43:08 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
QA Whiteboard: [MGSEI-Triage+]
Attachment #8689367 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5?(mpotharaju)
Comment on attachment 8689367 [details] [review]
[gaia] KevinGrandon:bug_1225765_gallery_gaia_menu_port > mozilla-b2g:master

Approved for 2.5 uplift
Attachment #8689367 - Flags: approval-gaia-v2.5?(mpotharaju) → approval-gaia-v2.5+
Hi Jenny,

Could you help to verify this bug on v2.5?

Thank you very much.
Flags: needinfo?(zhangmingyu)
This bug has been verified as "pass" on the latest build of Aries KK v2.5 and Flame KK v2.5 512mb by the STR in comment 0 .

Actual result: The "Cancel" button is appear as an oval button.

See attachment: Verified_FlameKK_v2.5.png
Reproduce rate: 0/10.

Device: Aries KK v2.5( Pass )
Build ID               20151223153111
Gaia Revision          8db2cdd9eb9b42932c4dfc86d109b3e46c220809
Gaia Date              2015-12-23 13:30:29
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/6fac3536a96a87185a6415d6ae2c36a85612e863
Gecko Version          44.0
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151223.144147
Firmware Date          Wed Dec 23 14:41:54 UTC 2015
Bootloader             s1

Device: Flame KK v2.5 512mb( Pass )
Build ID               20151223152613
Gaia Revision          8db2cdd9eb9b42932c4dfc86d109b3e46c220809
Gaia Date              2015-12-23 13:30:29
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/6fac3536a96a87185a6415d6ae2c36a85612e863
Gecko Version          44.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151223.143931
Firmware Date          Wed Dec 23 14:39:41 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Flags: needinfo?(zhangmingyu)
Status: RESOLVED → VERIFIED
Patch landed on 2.5. Updating blocking b2g flag.
blocking-b2g: 2.5? → 2.5+
You need to log in before you can comment on or make changes to this bug.