Closed Bug 1226612 Opened 4 years ago Closed 2 years ago

[RTL] In Persian RTL the datepicker's year is composed of a number and a suffix, causing severe overlapping

Categories

(Firefox OS Graveyard :: Gaia::Components, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+)

RESOLVED WONTFIX
blocking-b2g 2.5+

People

(Reporter: nefzaoui, Unassigned)

References

Details

Attachments

(2 files)

Attached image 2015-11-20-09-54-39.png
It looks like in Persian's calendar (Hijri Shamsi, or Solar Hijri) the year is composed of two elements: a number and a suffix.
For example
۱۲۷۸ ه‍.ش.
Which translates to: "1278 H.S."
this is causing the year section in the datepicker to look overlapping.

Arash from the Persian community suggests that if there is a way to completely remove the suffix it would be better, but he's open to a CSS fix (adding a screenshot in next comment).

I think this should be fixed for 2.6 and uplifted to 2.5 given the fact that the overlapping is severe and makes it almost impossible to read the year number.
Attached image CSS fix screenshot
need-info'ing Zibi to see if there's something we can do to completely remove the suffix? Is this mozIntl-related?
need-info'ing Josh to see if we should block on 2.5 given the severity?
Flags: needinfo?(jocheng)
Flags: needinfo?(gandalf)
> if there's something we can do to completely remove the suffix?

Not yet. It will be with bug 1216150 because it's just that Intl believes that in `fa` year should always come with token era.

So what's returned is <year> <era>. We could use formatToParts once we'll have it to remove era.
Flags: needinfo?(gandalf)
(In reply to Ahmed Nefzaoui [:Nefzaoui] from comment #2)

> need-info'ing Josh to see if we should block on 2.5 given the severity?

Mark P1 and 2.5+ base on severity. Also mark dependent bug 1216150 2.5+
blocking-b2g: --- → 2.5+
Flags: needinfo?(jocheng)
Priority: -- → P1
Depends on: 1216150
Summary: In Persian RTL the datepicker's year is composed of a number and a suffix, causing severe overlapping → [RTL] In Persian RTL the datepicker's year is composed of a number and a suffix, causing severe overlapping
Blocks: 1181944
Duplicate of this bug: 1228534
This may be fixed now on master, but it may also not be. But if it's not, I should be able to fix it easily, just need STR.
(In reply to Zibi Braniecki [:gandalf][:zibi] from comment #6)
> This may be fixed now on master, but it may also not be. But if it's not, I
> should be able to fix it easily, just need STR.

Sorry for very very very late response! I'm not sure if I have to give feedback on this bug or open a new one since FirefoxOS is not an active project anymore and this is a really about formatToParts() function you implemented. Please guide me and I'll do the right thing.

I tested this function on Firefox 51, the current aurora, and it doesn't work for "fa" (our locale). I think the root of the problem is wrong data for "fa" on CLDR. It seems that era by default is stuck to the year and it doesn't separate them.

Here is the code I tested on Firefox console:

var formatter = new Intl.DateTimeFormat("fa", {
  year: 'numeric',
  month: 'numeric',
  day: 'numeric',
});

"۱۳۹۵/۷/۱۲ ه‍.ش."

The only way that I don't get the era (ه‍.ش) is to remove year.
Flags: needinfo?(gandalf)
:Arash-M - yes, this is the current data format returned by CLDR.

Same values are returned by all browsers that use CLDR (Chrome, Firefox, Safari etc.)

If you believe it to be wrong - can you please report a bug in http://unicode.org/cldr/trac/report (you don't need to create an account). This way we can fix it for everyone.

Thanks!
Flags: needinfo?(gandalf)
(In reply to Zibi Braniecki [:gandalf][:zibi] from comment #8)
> If you believe it to be wrong - can you please report a bug in
> http://unicode.org/cldr/trac/report (you don't need to create an account).
> This way we can fix it for everyone.

Thank you Zibi for helping out. I just created a ticket[1] explaining the issue.

[1] http://unicode.org/cldr/trac/ticket/9838
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.