Closed Bug 1226742 Opened 8 years ago Closed 8 years ago

Port bug 1208295 - display notification permissions from the notification settings menu

Categories

(SeaMonkey :: Passwords & Permissions, defect)

SeaMonkey 2.41 Branch
defect
Not set
normal

Tracking

(seamonkey2.40 unaffected, seamonkey2.41 fixed, seamonkey2.42 fixed)

RESOLVED FIXED
seamonkey2.42
Tracking Status
seamonkey2.40 --- unaffected
seamonkey2.41 --- fixed
seamonkey2.42 --- fixed

People

(Reporter: neil, Assigned: neil)

Details

Attachments

(1 file)

Web notifications now support an additional menu with items to block notifications and open notification settings. The notification blocking ties into the existing permission management but the settings generates a notifications-open-settings observer notification which needs to be handled by the suite glue somehow.
Attached patch Possible patchSplinter Review
Attachment #8690542 - Flags: review?(philip.chee)
Comment on attachment 8690542 [details] [diff] [review]
Possible patch

As far as I can tell this patch *should* work. But I'm not getting anything when I click on the "Notification settings" button. I put a console.log and |case "notifications-open-settings":| isn't even called. Is there a pref I should flip?

I'll do another build tonight to see if anything changes.
Flags: needinfo?(neil)
Comment on attachment 8690542 [details] [diff] [review]
Possible patch

For some reason I had notification.feature.enabled set to true. Setting it to false allows this patch to work.
Flags: needinfo?(neil)
Attachment #8690542 - Flags: review?(philip.chee) → review+
Assignee: nobody → neil
Status: NEW → ASSIGNED
Comment on attachment 8690542 [details] [diff] [review]
Possible patch

[Triage Comment]

Backport to SeaMonkey 2.41

[Approval Request Comment]
Regression caused by (bug #): Not a regression. Part of bug 1208295
(Open content preferences after receiving notifications-open-settings)
User impact if declined: Does not open the data manager/permissions tab when the settings button in the OSX alert notification is clicked.
Testing completed (on m-c, etc.): Yes
Risk to taking this patch (and alternatives if risky): low to none risk.
String changes made by this patch: None.
Attachment #8690542 - Flags: approval-comm-beta+
Pushed to SeaMonkey 2.41 (comm-beta)
https://hg.mozilla.org/releases/comm-beta/rev/6e294a71e964
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.