[rfe] Add recapture the homepage checkbox on installer wizard screen

VERIFIED FIXED in mozilla1.0

Status

SeaMonkey
Installer
--
enhancement
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Gregg Landskov (gone), Assigned: Curt Patrick (gone))

Tracking

Trunk
mozilla1.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mcp-working][adt2])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
From the spec:  http://client.mcom.com/machv/xpinstall/WizardContent.html

Screen 5 - Download Options

Add the recapture the homepage checkbox to this screen, below the download path.
 After the pre-checked box, the text should say, 
" Make Netscape.com my homepage. "  

The title of the screen should be changed as well, maybe just
"Netscape 6 Setup - Additional Options" 

Jatin - any input from you on those two items would be welcome.

screenshot posted at: 
http://client.mcom.com/machv/xpinstall/Images/5_DownloadOptions.gif
When you implement this be sure to have a config.ini setting to say whether this
is enabled or not (as is done for Quick Launch and others) so the Mozilla builds
can have this turned off.
Assignee: dveditz → curt
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

17 years ago
QA Contact: bugzilla → gbush
Summary: Add recapture the homepage checkbox on installer wizard screen → Feature - Add recapture the homepage checkbox on installer wizard screen

Comment 2

17 years ago
Suggested wording:
"Make Netscape.com my home page."

"Additional Options" seems more appropriate then "Download Options."
(Assignee)

Updated

17 years ago
Blocks: 110838
(Assignee)

Updated

17 years ago
No longer blocks: 110838
(Assignee)

Updated

17 years ago
Blocks: 116969
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: nsbeta1
Summary: Feature - Add recapture the homepage checkbox on installer wizard screen → [rfe] Add recapture the homepage checkbox on installer wizard screen
Target Milestone: --- → mozilla1.0
(Assignee)

Updated

17 years ago
Depends on: 122540

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+
(Assignee)

Updated

17 years ago
Whiteboard: [mcp-working]

Comment 3

17 years ago
Yes, please provide an option to remove/disable this from the installer UI. Not
all vendor of Mozilla would like to provide this option to their users.
Blocks: 96876
(Assignee)

Comment 4

17 years ago
I've added bug 128481 to track the need to clean up the code now that the Site
Selector functionality will no longer be supported in the UI.
(Assignee)

Comment 5

17 years ago
Created attachment 73791 [details] [diff] [review]
0.1 patch

All the functionality to recapture the homepage is in this patch, but it is all

turned off in the config.it settings.  Although the settings would be turned
off by default anyway, I have explicitely turned them off with comments about
what their pupose is.

NS patch to follow will turn install the required component and turn on the
functionality.
(Assignee)

Comment 6

17 years ago
Created attachment 74228 [details] [diff] [review]
.02 patch

After talking with Sean, this patch:
- Fixes a blocker in the first patch.
- Switches reference to the DOWNLOAD_OPTIONS_DIALOG to say
ADDITIONAL_OPTIONS_DIALOG.
- Changed DIALOGEX to DIALOG DISCARDABLE in rc file.
- Hiding instead of disabling the "Save Download" option stuff when it is not
applicable.
- Always calling the dialog "Additional Options".  (I was calling it "Save
Download Option" for mozilla.)
Attachment #73791 - Attachment is obsolete: true

Comment 7

17 years ago
Comment on attachment 74228 [details] [diff] [review]
.02 patch

You forgot to change the title string:
  +Title=$ProductName$ Setup - Save Download Option

other than that, r=ssu

Is there a bug filed on changing the new checkbox description?
Attachment #74228 - Flags: review+
(Assignee)

Comment 8

17 years ago
Here is the suggested verbiage from Gregg Landskov to go with the checkbox:

"Netscape.com is the perfect compliment to your Netscape Software"

Of course, I'll have to put something less Netscape in as a placeholder for
mozilla.  Anybody got a strong opinion about what that should say?  Will
something like "The following checkbox gives users the option of reverting to
the default home page" do?
Sure that sounds good. It doesn't really matter because this option is invisible
for mozilla folks anyway, right?
(Assignee)

Comment 10

17 years ago
Yes, it is invisible.  I was going to set it to an empty string but looks pretty
funny if someone fiddles with the config file to see how it works.  They'd
potentially get a checkbox all alone on the dialog.  So it seems like something
inoccuous is a good idea.

I'll add that to my patch.  Still need sr= on this before I can go for
permission to check this in.
Comment on attachment 74228 [details] [diff] [review]
.02 patch

This solves the specified problem, but it's not extensible. What do you do if
marketing comes back with the "reset the search engine" request? You can't have
multiple criteria, and even if you could you'd end up with 4 run-app sections
(n^2 in the general case).

This is smelling like a temporary hack. Should I sr= anyway?
(Assignee)

Comment 12

17 years ago
I'm for putting this in, since it does meet the immediate requirement, and
letting it bake to see if extensibility is even desirable.  If having this
functionality engenders ideas for other related functionality that is desirable
then we can put more brainpower into thinking up a more flexible solution.  On
the other hand, if this is all we ever want (I suspect it may be) than we don't
waste time overengineering it.
(Reporter)

Comment 13

17 years ago
we are not expecting to add capability for search or anything else to this list
at this time.  While realizing this could change, I think we should get this in
and move on due to the chance being slim to none.

If it is does indeed come to pass that it needs to become extensible, there will
need to be significant justification from higher up to do anything, and even
then it will simply need to come after rtm.
Comment on attachment 74228 [details] [diff] [review]
.02 patch

sr=dveditz with the caveat that this non-extensible hack needs to get ripped
out or re-written when we re-jigger the config.ini language to be consistent
across platforms again.
Attachment #74228 - Flags: superreview+

Comment 15

17 years ago
adt2 per triage
Whiteboard: [mcp-working] → [mcp-working][adt2]

Comment 16

17 years ago
test build passed

Comment 17

17 years ago
Comment on attachment 74228 [details] [diff] [review]
.02 patch

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #74228 - Flags: approval+
(Assignee)

Comment 18

17 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 19

17 years ago
verified on build 20020632503
Status: RESOLVED → VERIFIED

Updated

16 years ago
No longer blocks: 116969
Blocks: 116969

Comment 20

16 years ago
[RFE] is deprecated in favor of severity: enhancement.  They have the same meaning.
Severity: normal → enhancement
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.