Closed Bug 1227024 Opened 4 years ago Closed 4 years ago

Disable GTK3 in Firefox 43 Beta & 44

Categories

(Core :: Widget: Gtk, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
firefox43 --- fixed
firefox44 --- fixed

People

(Reporter: karlt, Assigned: karlt)

References

Details

Attachments

(2 files)

Although the GTK3 port is ready to ship, the update experience will be poor
for users without GTK3 installed.  We don't know what proportion of users that would be.

Reverting to GTK2 for 43 beta and maybe 44 beta also would give some time
to sort out bug 1227023.
This is the same patch from bug 1207310.

Approval Request Comment
[Feature/regressing bug #]: GTK3 port - bug 1186229
[User impact if declined]: 
Updates fail for some users with no UI and old builds stop working.
[Describe test coverage new/current, TreeHerder]:
The GTK2 port hasn't been tested by 43 users, but the code has changed very little.
[Risks and why]: 
Risks are most likely in native widget appearance, if chrome styling or native rendering code has accidentally made assumptions about the GTK version in use.
[String/UUID change made/needed]: none.
Attachment #8690661 - Flags: approval-mozilla-beta?
Comment on attachment 8690661 [details] [diff] [review]
Switch from GTK3 to GTK2

Disabling GTK3 for 43, ok to land on beta
Attachment #8690661 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/77cb8a3a21dd
Assignee: nobody → karlt
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Comment on attachment 8690661 [details] [diff] [review]
Switch from GTK3 to GTK2

Sice we're pushing Gtk+3 switch to 45, we need this again on beta, which is now 44. Ideally, we'd need this landed before beta 1.
Attachment #8690661 - Flags: approval-mozilla-beta+ → approval-mozilla-beta?
Comment on attachment 8690661 [details] [diff] [review]
Switch from GTK3 to GTK2

We need this in Beta44. Approved.
Attachment #8690661 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Summary: Disable GTK3 in Firefox 43 Beta → Disable GTK3 in Firefox 43 Beta & 44
Here's a patch for beta 44 since the one for 43 had conflicts. Planning on pushing this myself if the reconfig finishes in time, but posting it here in case I have to run for my appointment before that finishes.
Karl, as it seems that gtk3 is not ready for GA  in 45 (bug 1199602 & bug 1239962), I would like to disable it. OK with you?
Flags: needinfo?(karlt)
I agree that bug 1205199 looks like a reason to hold back GTK3 from 45.

We don't have evidence that bug 1199602 is caused by GTK3.
If that were the only concern then I would ask for a report without e10s before disabling GTK3.
Flags: needinfo?(karlt)
Created bug 1245476 as followup
You need to log in before you can comment on or make changes to this bug.