Closed Bug 1227124 Opened 5 years ago Closed 4 years ago

[E10] AtkTable interface broken/not-implemented(?) in Nightly

Categories

(Core :: Disability Access APIs, defect)

Unspecified
Linux
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox45 --- affected

People

(Reporter: jdiggs, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: aes+)

Attachments

(1 file)

Steps to reproduce:
1. Launch the attached pyatspi accessible-event listener in a terminal
2. Launch Nightly and load data:text/html,<table><tr><td>1</td></tr></table>

Expected results: "SUCCESS" appears in the terminal
Actual results: "FAIL! Table doesn't implement the table interface"

I've not yet pinned down when this regression was introduced. But stable (42.0) is fine. And I'm pretty sure this is a recentish regression.

Setting Severity to Major because *the* way Orca provides access to tables is through the no-longer-functional/implemented table interface.
FWIW, not a problem on Windows, and most probably not in the platform-independent layer, or our tests would have gone havoc. So most likely Linux-specific. Joanie, out of interest, is this with and without E10S?
Flags: needinfo?(jdiggs)
Heh. I had forgotten that I was using E10s -- credit to you guess making it pretty accessible I guess. :) 
Anyway, you are correct: If I disable E10s, the table interface is implemented.
Flags: needinfo?(jdiggs)
Blocks: e10sa11y2
Summary: AtkTable interface broken/not-implemented(?) in Nightly → [E10] AtkTable interface broken/not-implemented(?) in Nightly
Trevor to triage.
Flags: needinfo?(tbsaunde+mozbugs)
I'd expect this works now, Joanie do you still see a problem?
Flags: needinfo?(tbsaunde+mozbugs) → needinfo?(jdiggs)
Whiteboard: aes-linux
Whiteboard: aes-linux → aes+
Flags: needinfo?(tbsaunde+mozbugs)
Sorry for the delay in responding. It looks like Nightly with e10s enabled now has the expected AtkTable support. Closing as WORKSFORME.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(jdiggs)
Resolution: --- → WORKSFORME
Flags: needinfo?(tbsaunde+mozbugs)
You need to log in before you can comment on or make changes to this bug.