view-source: doesn't open new window with source

RESOLVED DUPLICATE of bug 78619

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 78619
16 years ago
13 years ago

People

(Reporter: Mathias Bogaert, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Example:
http://webfx.eae.net/dhtml/xblmarquee/progressbar.html

Notice that IE opens a new window clicking on the View source (which does a
"javascript:void (document.location='view-source:'+document.location)"). Mozilla
loads the source in the current document. Using Build ID 2002013003
WFM, linux 2002012909.
Actually, I see what you're saying now but that's my expected behaviour.  If I
specifically tell something that we are loading it in the current document's
location (document.location) then I expect it to load in the current window and
not a new one.

If you want a new window, call it with window.open()
Duplicate of "View-source: pages have a view source option if opened by
hyperlink"

*** This bug has been marked as a duplicate of 78619 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.