Put wptserve in a shared tools directory

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: maja_zf, Assigned: maja_zf)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

MozReview Requests

Submitter Diff Changes Open Issues Last Updated
Loading...
Error loading review requests:

Attachments

(1 attachment)

Right now wptserve is in testing/web-platform/tests/tools. Since we are likely to replace mozhttpd with wptserve in many tools, we should move wptserve into a common area. Maybe under testing/tools?

Context: I am currently replacing mozhttpd with wptserve in Marionette runner in Bug 1150512, which requires that I add wptserve to the common.tests.zip package. Before I do that, it makes sense to move wptserve out of testing/web-platform.
(Assignee)

Comment 1

3 years ago
Ted, does testing/tools sounds like a good place for wptserve?

James, what would moving wptserve affect on your side? Would you prefer to keep two copies of wptserve in-tree during a temporary "transition period"?
Flags: needinfo?(ted)
Flags: needinfo?(james)
The reason that it turns up in testing/web-platform/tests is that upstream it's a submodule of wpt-tools which in turn is a submodule of web-platform-tests. So it naturally ends up there as part of the wpt sync process.

I wouldn't mind it also ending up somewhere else, but removing the existing copy might be a non-trivial amount of work.
Flags: needinfo?(james)
(Assignee)

Comment 3

3 years ago
Looks like we're good to go.

See http://logs.glob.uno/?c=mozilla%23ateam&s=30+Nov+2015&e=30+Nov+2015#c1001304:
11:08 <maja_zf> ted: hi! any objections to putting a copy of wptserve under testing/tools? (Bug 1228661)
11:09 <ted> maja_zf: that's fine
Flags: needinfo?(ted)
(Assignee)

Updated

3 years ago
Assignee: nobody → mjzffr
(Assignee)

Comment 4

3 years ago
Created attachment 8693724 [details]
MozReview Request: Bug 1228661 - Copy wptserve to testing/tools; r?jgraham

Bug 1228661 - Copy wptserve to testing/tools; r?ahal

Copy of testing/web-platform/tests/tools/wptserve.
Corresponds to: https://github.com/w3c/wptserve.git
commit b6b082fb70c592c6164c76aa167ae4dc284ebb69
Attachment #8693724 - Flags: review?(ahalberstadt)
(Assignee)

Comment 5

3 years ago
Comment on attachment 8693724 [details]
MozReview Request: Bug 1228661 - Copy wptserve to testing/tools; r?jgraham

Review request updated; see interdiff: https://reviewboard.mozilla.org/r/26577/diff/1-2/
Attachment #8693724 - Attachment description: MozReview Request: Bug 1228661 - Copy wptserve to testing/tools; r?ahal → MozReview Request: Bug 1228661 - Copy wptserve to testing/tools; r?jgraham
Attachment #8693724 - Flags: review?(ahalberstadt) → review?(james)
Comment on attachment 8693724 [details]
MozReview Request: Bug 1228661 - Copy wptserve to testing/tools; r?jgraham

https://reviewboard.mozilla.org/r/26577/#review24075

So I haven't really checked anything here; I assume you just copied the files over. Did you check that you could actually use it?
Attachment #8693724 - Flags: review?(james)
(Assignee)

Comment 7

3 years ago
After some more conversations, I don't think we should go ahead with this for now. Pulling wptserve out of /testing/web-platform is troublesome, keeping a second copy under testing/tools up-to-date is troublesome, and in the end I really need is to include testing/web-platform/.../wptserve in common.tests.zip. So I'm resolving this and I filed Bug 1229467 instead.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.