[DOGFOOD] When changing folders, selection is messed up

VERIFIED FIXED in M11

Status

P3
blocker
VERIFIED FIXED
20 years ago
2 years ago

People

(Reporter: scottputterman, Assigned: scottputterman)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PR1])

(Assignee)

Description

20 years ago
I'm using the new onselect even in threadpane.  I'm not sure if this makes a
difference.
Open Mailnews
Select a folder.
Select a message in that folder.  Message is displayed
Change to a different folder
Select a message in the new folder. Message isn't displayed.

I've debugged this in my js and it looks like when we change folders, it thinks
the number of selected items is equal to the number of selected items in the
old folder plus the number of selected items in the new folder which means that
no message is displayed since we don't display messages when 2 or more messages
are selected.  In addition, ever message clicked on is added to the selection
without the ctrl or shift keys being pressed.

It looks like selection is not reset when the thread pane tree is rerooted.  I
do happen to know when a new folder is loaded and I could probably clear the
selection myself.  But, it seems like the tree would want to do this.

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M10

Comment 1

20 years ago
This is easy to fix.  I was doing this before.  I just forgot to move it over.

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED

Comment 2

20 years ago
Should be fixed, assuming that nodes are being removed like they should be.
(Assignee)

Comment 3

20 years ago
I'm pretty sure I pulled and built the correct files.  I'm stil leeing the same
problem.  I guess that means we have a leak?  I'll try a full build now to make
sure.

Updated

20 years ago
Status: RESOLVED → REOPENED

Updated

20 years ago
Resolution: FIXED → ---

Updated

20 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 4

20 years ago
adding hangas to cc.

Right now, will onselect fire when selection is removed?  Such as when you use
the control key to remove selection or when you reroot a tree.  We also need to
know this case.
(Assignee)

Comment 5

20 years ago
OK.  I just tried it out and the removing selection with the control key works.
I just wanted to make sure that we get an onselect when rerooting the tree
removes the selection.
(Assignee)

Updated

20 years ago
Blocks: 7778

Comment 6

20 years ago
I've noticed that if you click twice on the same item, then you get more items
selected:
In ThreadPaneSelectionChange().  Num Selected Items = 3
ctrl-clicking the item reduces this count by one and unselects the current item
visually, but then the next time you click or control-click it goes up again.

Updated

20 years ago
Blocks: 12669

Comment 7

20 years ago
Bulk move mail/news M10 bugs to M11

Updated

20 years ago
Severity: normal → blocker

Comment 8

20 years ago
This is a dogfood blocker for mail/news so I'm upgrading the severity.

I just saw this bug yesterday, so I think it's not fixed.

Updated

20 years ago
Whiteboard: [PR1]

Comment 9

20 years ago
This needs to be fixed for PR1, so I added a note to the Status Whiteboard.

This bug really drives me crazy.

Updated

20 years ago
Blocks: 12176
Summary: When changing folders, selection is messed up → [DOGFOOD] When changing folders, selection is messed up

Updated

20 years ago
OS: Windows NT → All
Hardware: PC → All

Comment 10

20 years ago
Just an update to note this is on all platforms, changing platform and OS to
all.  Still happens on 19990908 builds.

Comment 11

20 years ago
*** Bug 13496 has been marked as a duplicate of this bug. ***

Comment 12

20 years ago
Update:  tested with 19990914 win32 build, still a problem
(Assignee)

Comment 13

20 years ago
We're working on solutions where we will clear out the selection before
switching folders and address books.  I think this should work.  When we get
that working, I'll close out this bug and and open up a new one on the tree
widget.  I think it should still clear out the selection when rerooting, but if
we can work around this, this should be sufficient for beta.

Comment 14

20 years ago
Sorry, that was build 1999091310 M10 build not 19990914

Updated

20 years ago
Assignee: hyatt → putterman
Status: ASSIGNED → NEW

Comment 15

20 years ago
Using build 19990915 on win98 this appears to be fixed.  I think a workaround
fix went in so this is more user friendly.  Scott, did you want this marked as
fixed and open a new bug for removing the work around after the real fix goes
in?  Or do we leave this opened and change the severity?  Reassigning to
putterman for review
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

20 years ago
This is fixed for the 3pane.  Select a message in one folder.  Change folders,
and then select a new message. This should work now.

Updated

20 years ago
QA Contact: lchiang → esther

Comment 17

20 years ago
Need to verify on other platforms.  Win32 1999091508 build is fine.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 18

20 years ago
Using 19990922 builds on win98, mac and linux this is fixed for all.  Verified

Updated

20 years ago
No longer blocks: 12176
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.