Fix "Außenlichterkette" suggestions in German "Outdoor Christmas Lights"

RESOLVED INVALID

Status

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: guigs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2016-GBT-Y])

Attachments

(1 attachment)

Created attachment 8694329 [details]
Thunderbird Rechtschreibkorrektur.png

The attached png shows the proposals on the (correctly spelled) German
word "Außenlichterkette".

The proposals Außenlicher*d*kette, Außenlichter*b*kette and
Außenlichter*z*kette don't exist in any German I know.

"Außergerichtlich" is spelled fine, but doesn't has anything to do with
fairy lights.

Comment 1

3 years ago
This is not a Mozilla core bug. Please contact the person who maintains the German dictionary add-on:
https://addons.mozilla.org/en-US/firefox/addon/german-dictionary-de_de-for-sp/
https://addons.mozilla.org/en-US/firefox/addon/german-dictionary/
You didn't even specify which dictionary your using.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Are those add-ons actually something that get shipped by default in German-localized Firefox builds? If not, I'm not sure directing users there is helpful, unless they mention that they've installed one of those addons.)

I suspect this bug is about the default spellchecker for German localizations, & likely belongs in the German localization component. Reopening & reclassifying, for localizers to (hopefully) triage & decide how to handle.
Component: Spelling checker → de / German
Product: Core → Mozilla Localizations
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
German doesn't ship with a dictionary, so it's indeed a problem with one of the add-ons. 
http://hg.mozilla.org/releases/l10n/mozilla-aurora/de/file/default/extensions/

Comment 4

3 years ago
(In reply to Francesco Lodolo [:flod] from comment #3)
> German doesn't ship with a dictionary, so it's indeed a problem with one of
> the add-ons. 
So what do we do with the bug in this case?
(In reply to Jorg K (GMT+1) from comment #4)
> So what do we do with the bug in this case?

Not completely sure: the German team can definitely say if the request makes sense, but in order to fix it the dictionary maintainer will need to be contacted (once you figured out which one we're talking about).
I can reproduce the issue in Thunderbird 38.5.0 and not in LibreOffice 5.0.4.2. As far as I know, the dictionaries are the ones LibreOffice uses. Can the German ones be updated?
Flags: needinfo?(kairo)

Comment 7

3 years ago
(In reply to Jorg K (GMT+1) from comment #4)
> (In reply to Francesco Lodolo [:flod] from comment #3)
> > German doesn't ship with a dictionary, so it's indeed a problem with one of
> > the add-ons. 
> So what do we do with the bug in this case?

If it's the dictionary at fault, we close it as invalid, as the dictionary is not maintained by anyone at Mozilla. While I package it and make it available on AMO, it's straight out of the https://www.j3e.de/ispell/igerman98/ repository that is used for the LibreOffice dictionaries as well.

If the version of HunSpell that we use is at fault, it may be a valid bug and we might need to upgrade it to the same version that LibreOffice ships.
Flags: needinfo?(kairo)

Comment 8

3 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #7)
> If it's the dictionary at fault, we close it as invalid, as the dictionary
> is not maintained by anyone at Mozilla. While I package it and make it
> available on AMO, it's straight out of the
> https://www.j3e.de/ispell/igerman98/ repository that is used for the
> LibreOffice dictionaries as well.

That said, I see that Björn Jacke created a new version of the dictionary after two years of not updating it, I will release that version to AMO in the next week or two.

Comment 9

3 years ago
Robert, can you also shed some light on the confusion of the add-ons:
https://addons.mozilla.org/en-US/firefox/addon/german-dictionary-de_de-for-sp/
igerman98 / by B. Jacke / Version 20151028, Last Updated: October 28, 2015

https://addons.mozilla.org/en-US/firefox/addon/german-dictionary/
by KaiRo (that's you), Version 2.0.4, Last Updated: June 1, 2014
Looking inside the .dic file I see: Version: 20131206 (build 20140601)

Why are there two?
Which one is the right one?
Can we remove one to reduce confusion?

Looking for "lichter" in de-DE.dic, the 20151028 version, I get:

Gelichter/m
Lichterfest/EPSm
Lichterkette/Nm
Schlichter/FNSm
Schlichterspruch/Sm
gelichter/ozm
lichterfest/EPSozm
lichterkette/Nozm
lichterloh/A
schlichter/FNSozm
schlichterspruch/Sozm

Typing "außenlichterkette" into Thunderbird and then spell-checking, I get these suggestions:
Außenlichterkette
-außenlichterkette
Lichterkette
außergerichtlich

I can't even reproduce the problem, I don't see Außenlicher*d*kette, Außenlichter*b*kette or Außenlichter*z*kette anywhere (an no one has actually told us which dictionary they're using), so I'm closing this for the second time as invalid.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → INVALID

Comment 10

3 years ago
(In reply to Jorg K (GMT+1) from comment #9)
> Robert, can you also shed some light on the confusion of the add-ons:
> https://addons.mozilla.org/en-US/firefox/addon/german-dictionary-de_de-for-
> sp/
> igerman98 / by B. Jacke / Version 20151028, Last Updated: October 28, 2015
> 
> https://addons.mozilla.org/en-US/firefox/addon/german-dictionary/
> by KaiRo (that's you), Version 2.0.4, Last Updated: June 1, 2014
> Looking inside the .dic file I see: Version: 20131206 (build 20140601)
> 
> Why are there two?

Because I packaged the first ones for the older MySpell architecture (1.x series) that we had in the past and then updated to the newer HunSpell stuff once it was safe to do so (2.x series). Björn Jacke is maintaining the actual dictionaries and at some point suddenly published variants of himself without communicating with me or reacting to any emails of mine other than saying that he is unwilling to re-license his dictionary work in a form that we actually can ship with Firefox. He never actually released a repository version of the 20151028 version from what I saw, the last release (before the recent 20151220) was the one I packaged in my 2.0.4 packages (there are actually 3 variants, the main one for Germany, an extended one with words for Austria, and one with the different writing variants for Switzerland).

> Which one is the right one?

Both or none or whatever. Mine have more users as they have been around for way longer, his come directly from the dictionary maintainer, who is unwilling to communicate well with Mozilla though. The situation is bad all in all.

> Can we remove one to reduce confusion?

No, as the users who have one of them installed would not be migrated to the other one and be stuck with whatever they have installed. Our Add-on system has no way of migrating users from one add-on ID to another, so we are stuck with maintaining both for the future. Also, due to no useful communication or cooperation from Björn, there's not even a good way for improving the confusion.

Comment 11

3 years ago
Great. See bug 1229406 for French to see that it can be handled better ;-)
You need to log in before you can comment on or make changes to this bug.